adm5120: add experimental 3.14 kernel support
[15.05/openwrt.git] / target / linux / adm5120 / patches-3.14 / 103-mtd_trxsplit.patch
diff --git a/target/linux/adm5120/patches-3.14/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-3.14/103-mtd_trxsplit.patch
new file mode 100644 (file)
index 0000000..6266776
--- /dev/null
@@ -0,0 +1,23 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -60,6 +60,10 @@ config MTD_ROOTFS_SPLIT
+       bool "Automatically split 'rootfs' partition for squashfs"
+       default y
++config MTD_TRXSPLIT
++      bool "Automatically find and split TRX partitions"
++      default n
++
+ config MTD_REDBOOT_PARTS
+       tristate "RedBoot partition table parsing"
+       ---help---
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -16,6 +16,7 @@ obj-$(CONFIG_MTD_AR7_PARTS)  += ar7part.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS)       += bcm63xxpart.o
+ obj-$(CONFIG_MTD_BCM47XX_PARTS)       += bcm47xxpart.o
+ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
++obj-$(CONFIG_MTD_TRXSPLIT)    += trxsplit.o
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_BLKDEVS)     += mtd_blkdevs.o