adm5120: preliminary 2.6.32 support (closes: #6304)
[openwrt.git] / target / linux / adm5120 / patches-2.6.32 / 120-rb153_cf_driver.patch
diff --git a/target/linux/adm5120/patches-2.6.32/120-rb153_cf_driver.patch b/target/linux/adm5120/patches-2.6.32/120-rb153_cf_driver.patch
new file mode 100644 (file)
index 0000000..c8e2be4
--- /dev/null
@@ -0,0 +1,28 @@
+--- a/drivers/ata/Makefile
++++ b/drivers/ata/Makefile
+@@ -77,6 +77,7 @@ obj-$(CONFIG_PATA_PLATFORM)  += pata_plat
+ obj-$(CONFIG_PATA_AT91)       += pata_at91.o
+ obj-$(CONFIG_PATA_OF_PLATFORM)        += pata_of_platform.o
+ obj-$(CONFIG_PATA_ICSIDE)     += pata_icside.o
++obj-$(CONFIG_PATA_RB153_CF)   += pata_rb153_cf.o
+ # Should be last but two libata driver
+ obj-$(CONFIG_PATA_ACPI)               += pata_acpi.o
+ # Should be last but one libata driver
+--- a/drivers/ata/Kconfig
++++ b/drivers/ata/Kconfig
+@@ -597,6 +597,15 @@ config PATA_RADISYS
+         If unsure, say N.
++config PATA_RB153_CF
++      tristate "RouterBOARD 153 Compact Flash support"
++      depends on ADM5120_MACH_RB_153
++      help
++        This option enables support for a Compact Flash connected on
++        the RouterBOARD 153.
++
++        If unsure, say N.
++
+ config PATA_RB532
+       tristate "RouterBoard 532 PATA CompactFlash support"
+       depends on MIKROTIK_RB532