linux/adm5120: add 2.6.38 preliminary support
[openwrt.git] / target / linux / adm5120 / patches-2.6.32 / 009-adm5120_leds_switch_trigger.patch
index 272fb8f..2f6eaf0 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -315,4 +315,12 @@ config LEDS_TRIGGER_NETDEV
-         This allows LEDs to be controlled by network device activity.
-         If unsure, say Y.
+@@ -322,4 +322,12 @@ config LEDS_TRIGGER_USBDEV
+         This allows LEDs to be controlled by the presence/activity of
+         an USB device. If unsure, say N.
  
 +config LEDS_TRIGGER_ADM5120_SWITCH
 +      tristate "LED ADM5120 Switch Port Status Trigger"
@@ -15,8 +15,8 @@
  endif # NEW_LEDS
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -42,3 +42,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO)              += ledt
- obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+@@ -43,3 +43,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON)        +=
  obj-$(CONFIG_LEDS_TRIGGER_MORSE)      += ledtrig-morse.o
- obj-$(CONFIG_LEDS_TRIGGER_NETDEV)      += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV)     += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_USBDEV)     += ledtrig-usbdev.o
 +obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o