trivial changes
[15.05/openwrt.git] / target / image / x86 / Makefile
index adace07..7aa03b2 100644 (file)
@@ -7,6 +7,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+export PATH=$(TARGET_PATH):/sbin
 ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
 #")) # fix vim's broken syntax highlighting
 
@@ -54,5 +55,8 @@ define Image/Build
        cp $(LINUX_DIR)/arch/i386/boot/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
 endef
 
-
 $(eval $(call BuildImage))
+
+$(eval $(call RequireCommand,fdisk, \
+       Please install fdisk \
+))