new (last?) attempt at standardizing Makefiles
[openwrt.git] / package / zd1211 / Makefile
index 0c94cd1..e5d2c27 100644 (file)
@@ -13,24 +13,26 @@ PKG_NAME:=zd1211
 PKG_VERSION:=r69
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-driver-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-driver-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://zd1211.ath.cx/download/
 PKG_MD5SUM:=c14133a3d5b27927402a492e84d2467a
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-driver-$(PKG_VERSION)
+
 include $(INCLUDE_DIR)/package.mk
 
 #FIXME: add proper dependency handling on kmod-usb-core packages
 define Package/kmod-zd1211
-  SECTION:=drivers
-  CATEGORY:=Drivers
+  SECTION:=kernel
+  CATEGORY:=Kernel drivers
   DEPENDS:=@LINUX_2_6&&!LINUX_2_6_UML
   TITLE:=Driver for Zydas 1211 based USB devices
-  DESCRIPTION:=Driver for Zydas 1211 based USB devices \\\
-    Linux driver for the ZyDAS ZD1211 802.11b/g USB-WLAN-Chip.\\\
-    Initially contributed by ZyDAS, this driver is actively maintained by the \\\
-    open source community.
+  DESCRIPTION:=\
+       This package contains a Linux driver for the ZyDAS ZD1211 802.11b/g \\\
+       USB-WLAN-Chip.\\\
+       Initially contributed by ZyDAS, this driver is actively maintained by the \\\
+       open source community.
   URL:=http://zd1211.ath.cx/
   VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
 endef
@@ -50,10 +52,10 @@ define Build/Compile
 endef
 
 define Package/kmod-zd1211/install
-       install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
+       install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
        $(CP) $(PKG_BUILD_DIR)/zd1211.$(LINUX_KMOD_SUFFIX) \
                $(1)/lib/modules/$(LINUX_VERSION)/
-       install -m0755 -d $(1)/usr/sbin
+       install -d -m0755 $(1)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/apdbg $(1)/usr/sbin/
        $(CP) $(PKG_BUILD_DIR)/sta $(1)/usr/sbin/$(PKG_NAME)-sta
 endef