add a default for PKG_BUILD_DIR and PKG_INSTALL_DIR (will use KERNEL_BUILD_DIR if...
[openwrt.git] / package / util-linux / Makefile
index 18fb251..05ad5cf 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 3822 2006-05-24 07:01:52Z nico $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -12,7 +12,6 @@ PKG_NAME:=util-linux
 PKG_VERSION:=2.12r
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
        http://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
@@ -21,8 +20,6 @@ PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
 PKG_MD5SUM:=c261230b27fc0fbcc287c76884caf2d3
 PKG_CAT:=zcat
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/util-linux/Default
@@ -56,6 +53,7 @@ define Package/swap-utils
        - swapoff
 endef
 
+TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib
 define Build/Compile
        $(call Build/Compile/Default, \
                OPT="$(TARGET_CFLAGS)" \
@@ -70,7 +68,7 @@ define Package/Template
                rm -f $(PKG_BUILD_DIR)/.built; \
                $(MAKE) $(PKG_BUILD_DIR)/.built; \
        fi
-       install -d -m0755 $(2)
+       $(INSTALL_DIR) $(2)
        $(CP) $(PKG_INSTALL_DIR)/$(1) $(2)/
 endef