add openssl
[openwrt.git] / package / rules.mk
index d436df8..77a6595 100644 (file)
@@ -6,12 +6,16 @@ endif
 
 define Build/DefaultTargets
   ifeq ($(DUMP),)
-    ifeq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . | tee /tmp/xy1),.)
-      $(PKG_BUILD_DIR)/.prepared: package-clean
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(TOPDIR)/package/rules.mk),$(PKG_BUILD_DIR))
+      ifeq ($(CONFIG_AUTOREBUILD),y)
+        $(PKG_BUILD_DIR)/.prepared: package-clean
+      endif
     endif
 
-    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR) | tee /tmp/xy2),$(IPKG_$(1)))
-      $(PKG_BUILD_DIR)/.built: package-rebuild
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
+      ifeq ($(CONFIG_AUTOREBUILD),y)
+        $(PKG_BUILD_DIR)/.built: package-rebuild
+      endif
     endif
   endif
 
@@ -28,14 +32,19 @@ define Build/DefaultTargets
   $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
        $(call Build/Compile)
        touch $$@
-    
-  $(PKG_BUILD_DIR)/.dev-installed: $(PKG_BUILD_DIR)/.built
+
+  $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
        $(call Build/InstallDev)
        touch $$@
-    
+       
+  ifdef Build/InstallDev
+    compile-targets: $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
+  endif
+
   package-clean: FORCE
        $(call Build/Clean)
        $(call Build/UninstallDev)
+       rm -f $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
 
   package-rebuild: FORCE
        @-rm $(PKG_BUILD_DIR)/.built
@@ -51,7 +60,15 @@ define Package/Default
   DEPENDS:=
   MAINTAINER:=OpenWrt Developers Team <openwrt-devel@openwrt.org>
   SOURCE:=$(patsubst $(TOPDIR)/%,%,${shell pwd})
-  VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
+  ifneq ($(PKG_VERSION),)
+    ifneq ($(PKG_RELEASE),)
+      VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
+    else
+      VERSION:=$(PKG_VERSION)
+    endif
+  else
+    VERSION:=$(PKG_RELEASE)
+  endif
   PKGARCH:=$(ARCH)
   PRIORITY:=optional
   DEFAULT:=
@@ -134,8 +151,7 @@ define BuildPackage
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
        ( \
                DEPENDS=; \
-               for depend in $$(IDEPEND_$(1)); do \
-                       [ "$$$${depend%%%%%%%%[A-Za-z]*}" = "@" ] && continue; \
+               for depend in $$(filter-out @%,$$(IDEPEND_$(1))); do \
                        DEPENDS=$$$${DEPENDS:+$$$$DEPENDS, }$$$${depend##+}; \
                done; \
                echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
@@ -154,6 +170,9 @@ define BuildPackage
   $$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
+       -find $$(IDIR_$(1)) -name CVS | xargs rm -rf
+       -find $$(IDIR_$(1)) -name .svn | xargs rm -rf
+       -find $$(IDIR_$(1)) -name '.#*' | xargs rm -f
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
 
@@ -226,12 +245,11 @@ endef
 
 define Build/Compile/Default
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
                CC=$(TARGET_CC) \
                CROSS="$(TARGET_CROSS)" \
-               PREFIX="$$(IDIR_$(1))" \
-               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include" \
                ARCH="$(ARCH)" \
-               DESTDIR="$$(IDIR_$(1))" \
                $(1);
 endef
 
@@ -239,16 +257,6 @@ define Build/Compile
   $(call Build/Compile/Default,)
 endef
 
-define Build/InstallDev
-endef
-
-define Build/Clean
-       $(MAKE) clean
-endef
-
-define Build/UninstallDev
-endef
-
 ifneq ($(DUMP),)
   dumpinfo: FORCE
        @$(DUMPINFO)
@@ -261,7 +269,7 @@ else
   prepare: $(PKG_BUILD_DIR)/.prepared
   configure: $(PKG_BUILD_DIR)/.configured
 
-  compile-targets: $(PKG_BUILD_DIR)/.dev-installed
+  compile-targets:
   compile: compile-targets
 
   install-targets:
@@ -270,5 +278,6 @@ else
   clean-targets:
   clean: FORCE
        @$(MAKE) clean-targets
+       $(call Build/Clean)
        rm -rf $(PKG_BUILD_DIR)
 endif