add openssl
[openwrt.git] / package / rules.mk
index 1fd6f2a..77a6595 100644 (file)
@@ -7,11 +7,15 @@ endif
 define Build/DefaultTargets
   ifeq ($(DUMP),)
     ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(TOPDIR)/package/rules.mk),$(PKG_BUILD_DIR))
-      $(PKG_BUILD_DIR)/.prepared: package-clean
+      ifeq ($(CONFIG_AUTOREBUILD),y)
+        $(PKG_BUILD_DIR)/.prepared: package-clean
+      endif
     endif
 
     ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
-      $(PKG_BUILD_DIR)/.built: package-rebuild
+      ifeq ($(CONFIG_AUTOREBUILD),y)
+        $(PKG_BUILD_DIR)/.built: package-rebuild
+      endif
     endif
   endif
 
@@ -253,10 +257,6 @@ define Build/Compile
   $(call Build/Compile/Default,)
 endef
 
-define Build/Clean
-       $(MAKE) clean
-endef
-
 ifneq ($(DUMP),)
   dumpinfo: FORCE
        @$(DUMPINFO)
@@ -278,5 +278,6 @@ else
   clean-targets:
   clean: FORCE
        @$(MAKE) clean-targets
+       $(call Build/Clean)
        rm -rf $(PKG_BUILD_DIR)
 endif