change defaults to check for configure script (avoids defining a null rule otherwise)
[openwrt.git] / package / rules.mk
index 8bf769d..3f79b9f 100644 (file)
@@ -1,4 +1,3 @@
-# default target
 ifneq ($(DUMP),)
 all: dumpinfo
 else
@@ -12,19 +11,31 @@ $(PKG_BUILD_DIR)/.prepared:
        $(call Build/Prepare)
        touch $$@
 
-$(PKG_BUILD_DIR)/.configured:
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        $(call Build/Configure)
        touch $$@
 
-$(PKG_BUILD_DIR)/.built:
+ifeq ($(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),.)
+$(PKG_BUILD_DIR)/.prepared: clean
+endif
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
        $(call Build/Compile)
        touch $$@
 
+package-clean:
+       $(call Build/Clean)
+       rm -f $(PKG_BUILD_DIR)/.built
+
+package-recompile:
+       rm -f $(PKG_BUILD_DIR)/.built
+
+.PHONY: package-clean package-recompile
+
 define Build/DefaultTargets
 endef
 endef
 
-
 define Package/Default
 CONFIGFILE:=
 SECTION:=opt
@@ -35,6 +46,8 @@ SOURCE:=$(patsubst $(TOPDIR)/%,%,${shell pwd})
 VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
 PKGARCH:=$(ARCH)
 PRIORITY:=optional
+DEFAULT:=
+MENU:=
 TITLE:=
 DESCRIPTION:=
 endef
@@ -43,46 +56,74 @@ define BuildPackage
 $(eval $(call Package/Default))
 $(eval $(call Package/$(1)))
 
-ifeq ($$(TITLE),)
+ifeq ($(TITLE),)
 $$(error Package $(1) has no TITLE)
 endif
-ifeq ($$(CATEGORY),)
+ifeq ($(CATEGORY),)
 $$(error Package $(1) has no CATEGORY)
 endif
-ifeq ($$(PRIORITY),)
+ifeq ($(PRIORITY),)
 $$(error Package $(1) has no PRIORITY)
 endif
-ifeq ($$(VERSION),)
+ifeq ($(VERSION),)
 $$(error Package $(1) has no VERSION)
 endif
-ifeq ($$(PKGARCH),)
+ifeq ($(PKGARCH),)
 PKGARCH:=$(ARCH)
 endif
+$(eval 
+ifeq ($(DESCRIPTION),)
+DESCRIPTION:=$(TITLE)
+endif
+)
 
 IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
 IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
 INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
 
-ifneq ($(PACKAGE_$(1)),)
-compile-targets: $$(IPKG_$(1))
+ifneq ($(CONFIG_PACKAGE_$(1)),)
+COMPILE_$(1):=1
 endif
 ifneq ($(DEVELOPER),)
-compile-targets: $$(IPKG_$(1))
+COMPILE_$(1):=1
 endif
-ifeq ($(PACKAGE_$(1)),y)
+ifeq ($(CONFIG_PACKAGE_$(1)),y)
 install-targets: $$(INFO_$(1))
 endif
 
+ifneq ($$(COMPILE_$(1)),)
+ifeq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $$(IPKG_$(1)) $(PKG_BUILD_DIR)),$(PKG_BUILD_DIR))
+$(PKG_BUILD_DIR)/.built: package-recompile
+endif
+
+compile-targets: $$(IPKG_$(1))
+endif
+
+
 IDEPEND_$(1):=$$(strip $$(DEPENDS))
 
 DUMPINFO += \
-       echo "Package: $(1)"; \
+       echo "Package: $(1)"; 
+ifneq ($(MENU),)
+DUMPINFO += \
+       echo "Menu: $(MENU)";
+endif
+ifneq ($(DEFAULT),)
+DUMPINFO += \
+       echo "Default: $(DEFAULT)";
+endif
+DUMPINFO += \
        echo "Version: $(VERSION)"; \
-       echo "Depends: $(IDEPEND_$(1))"; \
+       echo "Depends: $$(IDEPEND_$(1))"; \
+       echo "Category: $(CATEGORY)"; \
        echo "Title: $(TITLE)"; \
-       echo "$(DESCRIPTION)" | sed -e 's,\\,\n,g'; \
+       echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g';
+ifneq ($(URL),)
+DUMPINFO += \
        echo; \
-       echo "$(URL)"; \
+       echo "$(URL)";
+endif
+DUMPINFO += \
        echo "@@";
 
 
@@ -90,32 +131,30 @@ $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Depends: $(IDEPEND_$(1))" >> $$(IDIR_$(1))/CONTROL/control
+       echo "Depends: $$(IDEPEND_$(1))" >> $$(IDIR_$(1))/CONTROL/control
        echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Priority: $(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Maintainer: $(MAINTAINER)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Architecture: $(PKGARCH)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Description: $(TITLE)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "$(DESCRIPTION)" | sed -e 's,\\,\n ,g' >> $$(IDIR_$(1))/CONTROL/control
+       echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n ,g' >> $$(IDIR_$(1))/CONTROL/control
        chmod 644 $$(IDIR_$(1))/CONTROL/control
        for file in conffiles preinst postinst prerm postrm; do \
                [ -f ./ipkg/$(1).$$$$file ] && cp ./ipkg/$(1).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \
        done
 
-$$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built $(PACKAGE_DIR)
+$$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built
        $(call Package/$(1)/install,$$(IDIR_$(1)))
+       mkdir -p $(PACKAGE_DIR)
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
 
 $$(INFO_$(1)): $$(IPKG_$(1))
        $(IPKG) install $$(IPKG_$(1))
 
 $(1)-clean:
-       rm -f $$(IPKG_$(1))
+       rm -f $(PACKAGE_DIR)/$(1)_*
 clean: $(1)-clean
 
-PACKAGES += $(1)
-
 ifneq ($(__DEFAULT_TARGETS),1)
 $(eval $(call Build/DefaultTargets))
 endif
@@ -148,21 +187,50 @@ $(call Build/Prepare/Default)
 endef
 
 define Build/Configure/Default
-# TODO: add configurable default command
+       (cd $(PKG_BUILD_DIR); \
+       [ -x configure ] && \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --sbindir=/usr/sbin \
+               --libexecdir=/usr/lib \
+               --sysconfdir=/etc \
+               --datadir=/usr/share \
+               --localstatedir=/var \
+               --mandir=/usr/man \
+               --infodir=/usr/info \
+               $(DISABLE_NLS) \
+               $(1); \
+       )
 endef
 
 define Build/Configure
-$(call Build/Configure/Default)
 endef
 
 define Build/Compile/Default
-# TODO: add configurable default command
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) \
+               CROSS="$(TARGET_CROSS)" \
+               PREFIX="$$(IDIR_$(1))" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               ARCH="$(ARCH)" \
+               DESTDIR="$$(IDIR_$(1))"
 endef
 
 define Build/Compile
 $(call Build/Compile/Default)
 endef
 
+define Build/Clean
+       $(MAKE) clean
+endef
+
 ifneq ($(DUMP),)
 dumpinfo:
        $(DUMPINFO)
@@ -191,14 +259,9 @@ install:
        @$(CMD_TRACE) "installing... "
        @$(MAKE) install-targets $(MAKE_TRACE)
 
-mostlyclean:
 rebuild:
        $(CMD_TRACE) "rebuilding... "
-       @-$(MAKE) mostlyclean 2>&1 >/dev/null
-       if [ -f $(PKG_BUILD_DIR)/.built ]; then \
-               $(MAKE) clean $(MAKE_TRACE); \
-       fi
-       $(MAKE) compile $(MAKE_TRACE)
+       $(MAKE) package-clean compile $(MAKE_TRACE)
 
 $(PACKAGE_DIR):
        mkdir -p $@
@@ -210,4 +273,4 @@ clean:
        rm -rf $(PKG_BUILD_DIR)
 endif
 
-.PHONY: all source prepare compile install clean dumpinfo
+.PHONY: all source prepare compile install clean rebuild dumpinfo compile-targets install-targets clean-targets