[kernel] move lots of kernel related packages to the new system/ folder
[openwrt.git] / package / rtc-rv5c386a / Makefile
diff --git a/package/rtc-rv5c386a/Makefile b/package/rtc-rv5c386a/Makefile
deleted file mode 100644 (file)
index e13ead5..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-#
-# Copyright (C) 2006-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=rtc-rv5c386a
-PKG_RELEASE:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define KernelPackage/rtc-rv5c386a
-  SUBMENU:=Other modules
-  DEPENDS:=@TARGET_brcm47xx
-  TITLE:=Driver for RTC RV5C386A (used in WL-700gE and WL-HDD)
-  AUTOLOAD:=$(call AutoLoad,70,rtc)
-  FILES:=$(PKG_BUILD_DIR)/rtc.ko
-endef
-
-define Build/Prepare
-       mkdir -p $(PKG_BUILD_DIR)
-       $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
-define Build/Compile
-       $(MAKE) -C "$(LINUX_DIR)" \
-               CROSS_COMPILE="$(TARGET_CROSS)" \
-               ARCH="$(LINUX_KARCH)" \
-               SUBDIRS="$(PKG_BUILD_DIR)" \
-               EXTRA_CFLAGS="$(BUILDFLAGS)" \
-               modules
-endef
-
-$(eval $(call KernelPackage,rtc-rv5c386a))