usbutils: add from /packages, clean up, add myself as maintainer
[openwrt.git] / package / robocfg / Makefile
index c0e7e2c..4bc72f5 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -20,9 +19,11 @@ define Package/robocfg
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=BCM5325E/536x switch configuration utility
-  DESCRIPTION:=\
-       This package contains an utility for configuring the Broadcom BCM5325E/536x \\\
-       based switches.
+endef
+
+define Package/robocfg/description
+ This package contains an utility for configuring the Broadcom BCM5325E/536x 
+ based switches.
 endef
 
 define Build/Prepare
@@ -31,8 +32,8 @@ define Build/Prepare
 endef
 
 define Package/robocfg/install
-       install -d -m0755 $(1)/sbin
-       install -m0755 $(PKG_BUILD_DIR)/robocfg $(1)/sbin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/robocfg $(1)/sbin/
 endef
 
 $(eval $(call BuildPackage,robocfg))