pptp: fix installation path for netifd proto handler
[openwrt.git] / package / pptp / Makefile
index 018e9b5..51bac8a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2008 OpenWrt.org
+#
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptp
 PKG_VERSION:=1.7.1
-PKG_RELEASE:=2
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/pptpclient
@@ -21,21 +21,39 @@ define Package/pptp
   SECTION:=net
   CATEGORY:=Network
   TITLE:=PPTP client
+  MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
   URL:=http://pptpclient.sourceforge.net/
-  DEPENDS:=+ppp +kmod-gre
+  DEPENDS:=+ppp +kmod-gre +resolveip +ip
 endef
 
-define Package/pptp/daemon
+define Package/pptp/description
  This package contains a PPTP (Point-to-Point Tunneling Protocol) client.
 endef
 
-define Package/pptp/install
+define Package/pptp/conffiles
+/etc/ppp/options.pptp
+endef
+
+MAKE_FLAGS += OPTIMIZE="$(TARGET_CFLAGS)"
+
+ifneq ($(CONFIG_PACKAGE_netifd),)
+  define Package/pptp/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/ppp
+       $(INSTALL_DATA) ./files/options.pptp $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/lib/netifd/proto/
+       $(INSTALL_BIN) ./files/pptp.sh $(1)/lib/netifd/proto/
+  endef
+else
+  define Package/pptp/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/ppp
        $(INSTALL_DATA) ./files/options.pptp $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_BIN) ./files/pptp.sh $(1)/lib/network/
-endef
+       $(INSTALL_DATA) ./files.old/pptp.sh $(1)/lib/network/
+  endef
+endif
 
 $(eval $(call BuildPackage,pptp))