oops... accidentally merged a broken patch
[openwrt.git] / package / pcmcia-cs / Makefile
index 2241c6f..6aca50f 100644 (file)
@@ -25,11 +25,13 @@ include $(INCLUDE_DIR)/package.mk
 define Package/pcmcia-cs
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@LINUX_2_4&&PCMCIA_SUPPORT
+  DEPENDS:=@PCMCIA_SUPPORT
   TITLE:=PCMCIA/Cardbus management utilities
   URL:=http://pcmcia-cs.sourceforge.net/
 endef
 
+$(PKG_BUILD_DIR)/.configured: $(LINUX_DIR)/.config
+
 define Build/Configure
        ( cd $(PKG_BUILD_DIR); \
                ./Configure \
@@ -51,6 +53,8 @@ define Build/Configure
 endef
 
 define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS)" \
                all install \
@@ -58,9 +62,9 @@ define Build/Compile
 endef
 
 define Package/pcmcia-cs/install
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/pcmcia $(1)/etc/
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/sbin/cardctl $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/sbin/cardmgr $(1)/usr/sbin/
 endef