[package] iproute2: workaround compile issues with gcc 4.8.x
[15.05/openwrt.git] / package / network / utils / iproute2 / patches / 000-warnings.patch
diff --git a/package/network/utils/iproute2/patches/000-warnings.patch b/package/network/utils/iproute2/patches/000-warnings.patch
new file mode 100644 (file)
index 0000000..8f07c38
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -30,8 +30,7 @@ CC = gcc
+ HOSTCC = gcc
+ DEFINES += -D_GNU_SOURCE
+ CCOPTS = -O2
+-WFLAGS := -Wall -Wstrict-prototypes -Werror -Wmissing-prototypes
+-WFLAGS += -Wmissing-declarations -Wold-style-definition
++WFLAGS := -Wall -Wstrict-prototypes
+ CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
+ YACCFLAGS = -d -t -v