openvpn: update to version 2.3.4
[openwrt.git] / package / network / services / samba36 / Makefile
index 2842c98..ba34838 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
-PKG_VERSION:=3.6.11
-PKG_RELEASE:=2
+PKG_VERSION:=3.6.23
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
-       http://ftp.samba.org/pub/samba/old-versions
+       http://ftp.samba.org/pub/samba/stable
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=9039e0ab3e4fc632ff0a1a8f2433edb4
+PKG_MD5SUM:=2f7aee1dc5d31aefcb364600915b31dc
 
 PKG_LICENSE:=GPLv3
 PKG_LICENSE_FILES:=COPYING
@@ -49,7 +49,7 @@ endef
 define Package/samba36-server/config
        config PACKAGE_SAMBA_MAX_DEBUG_LEVEL
                int "Maximum level of compiled-in debug messages"
-               depends PACKAGE_samba36-server || PACKAGE_samba36-client
+               depends on PACKAGE_samba36-server || PACKAGE_samba36-client
                default -1
 
 endef
@@ -114,6 +114,7 @@ CONFIGURE_ARGS += \
        --without-libnetapi \
        --without-libsmbclient \
        --without-libsmbsharemodes \
+       --without-libtevent \
        --without-libaddns \
        --with-shared-modules=pdb_tdbsam,pdb_wbc_sam,idmap_nss,nss_info_template,auth_winbind,auth_wbc,auth_domain