hostapd: update to 2014-10-25
[15.05/openwrt.git] / package / network / services / hostapd / patches / 600-ubus_support.patch
index 4738da2..fcaddbc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/hostapd/Makefile
 +++ b/hostapd/Makefile
-@@ -116,6 +116,11 @@ OBJS += ../src/common/wpa_common.o
+@@ -117,6 +117,11 @@ OBJS += ../src/common/wpa_common.o
  
  OBJS += ../src/eapol_auth/eapol_auth_sm.o
  
@@ -22,7 +22,7 @@
  
  struct wpa_ctrl_dst;
  struct radius_server_data;
-@@ -99,6 +100,7 @@ struct hostapd_data {
+@@ -102,6 +103,7 @@ struct hostapd_data {
        struct hostapd_iface *iface;
        struct hostapd_config *iconf;
        struct hostapd_bss_config *conf;
@@ -30,7 +30,7 @@
        int interface_added; /* virtual interface added for this BSS */
        unsigned int started:1;
  
-@@ -254,6 +256,8 @@ struct hostapd_iface {
+@@ -275,6 +277,8 @@ struct hostapd_iface {
        struct hostapd_config *conf;
        char phy[16]; /* Name of the PHY (radio) */
  
@@ -41,7 +41,7 @@
                HAPD_IFACE_DISABLED,
 --- /dev/null
 +++ b/src/ap/ubus.c
-@@ -0,0 +1,373 @@
+@@ -0,0 +1,408 @@
 +/*
 + * hostapd / ubus support
 + * Copyright (c) 2013, Felix Fietkau <nbd@openwrt.org>
@@ -55,6 +55,7 @@
 +#include "utils/eloop.h"
 +#include "common/ieee802_11_defs.h"
 +#include "hostapd.h"
++#include "wps_hostapd.h"
 +#include "sta_info.h"
 +#include "ubus.h"
 +
 +      return 0;
 +}
 +
++static int
++hostapd_bss_wps_start(struct ubus_context *ctx, struct ubus_object *obj,
++                      struct ubus_request_data *req, const char *method,
++                      struct blob_attr *msg)
++{
++      int rc;
++      struct hostapd_data *hapd = container_of(obj, struct hostapd_data, ubus.obj);
++
++      rc = hostapd_wps_button_pushed(hapd, NULL);
++
++      if (rc != 0)
++              return UBUS_STATUS_NOT_SUPPORTED;
++
++      return 0;
++}
++
++static int
++hostapd_bss_wps_cancel(struct ubus_context *ctx, struct ubus_object *obj,
++                      struct ubus_request_data *req, const char *method,
++                      struct blob_attr *msg)
++{
++      int rc;
++      struct hostapd_data *hapd = container_of(obj, struct hostapd_data, ubus.obj);
++
++      rc = hostapd_wps_cancel(hapd);
++
++      if (rc != 0)
++              return UBUS_STATUS_NOT_SUPPORTED;
++
++      return 0;
++}
++
 +static const struct ubus_method bss_methods[] = {
 +      UBUS_METHOD_NOARG("get_clients", hostapd_bss_get_clients),
 +      UBUS_METHOD("del_client", hostapd_bss_del_client, del_policy),
 +      UBUS_METHOD_NOARG("list_bans", hostapd_bss_list_bans),
++      UBUS_METHOD_NOARG("wps_start", hostapd_bss_wps_start),
++      UBUS_METHOD_NOARG("wps_cancel", hostapd_bss_wps_cancel),
 +};
 +
 +static struct ubus_object_type bss_object_type =
 +#endif
 --- a/src/ap/hostapd.c
 +++ b/src/ap/hostapd.c
-@@ -261,6 +261,7 @@ static void hostapd_free_hapd_data(struc
+@@ -263,6 +263,7 @@ static void hostapd_free_hapd_data(struc
        hapd->started = 0;
  
        wpa_printf(MSG_DEBUG, "%s(%s)", __func__, hapd->conf->iface);
        iapp_deinit(hapd->iapp);
        hapd->iapp = NULL;
        accounting_deinit(hapd);
-@@ -864,6 +865,8 @@ static int hostapd_setup_bss(struct host
+@@ -907,6 +908,8 @@ static int hostapd_setup_bss(struct host
        if (hapd->driver && hapd->driver->set_operstate)
                hapd->driver->set_operstate(hapd->drv_priv, 1);
  
        return 0;
  }
  
-@@ -1154,6 +1157,7 @@ int hostapd_setup_interface_complete(str
+@@ -1192,6 +1195,7 @@ int hostapd_setup_interface_complete(str
        if (err)
                goto fail;
  
        wpa_printf(MSG_DEBUG, "Completing interface initialization");
        if (iface->conf->channel) {
  #ifdef NEED_AP_MLME
-@@ -1265,6 +1269,7 @@ int hostapd_setup_interface_complete(str
+@@ -1322,6 +1326,7 @@ int hostapd_setup_interface_complete(str
  
  fail:
        wpa_printf(MSG_ERROR, "Interface initialization failed");
        hostapd_set_state(iface, HAPD_IFACE_DISABLED);
        wpa_msg(hapd->msg_ctx, MSG_INFO, AP_EVENT_DISABLED);
        if (iface->interfaces && iface->interfaces->terminate_on_error)
-@@ -1587,6 +1592,7 @@ void hostapd_interface_deinit_free(struc
+@@ -1648,6 +1653,7 @@ void hostapd_interface_deinit_free(struc
                   (unsigned int) iface->conf->num_bss);
        driver = iface->bss[0]->driver;
        drv_priv = iface->bss[0]->drv_priv;
                   __func__, driver, drv_priv);
 --- a/src/ap/ieee802_11.c
 +++ b/src/ap/ieee802_11.c
-@@ -542,7 +542,8 @@ failed:
+@@ -545,7 +545,8 @@ failed:
  
  
  static void handle_auth(struct hostapd_data *hapd,
  {
        u16 auth_alg, auth_transaction, status_code;
        u16 resp = WLAN_STATUS_SUCCESS;
-@@ -557,6 +558,11 @@ static void handle_auth(struct hostapd_d
+@@ -560,6 +561,11 @@ static void handle_auth(struct hostapd_d
        size_t resp_ies_len = 0;
        char *identity = NULL;
        char *radius_cui = NULL;
  
        if (len < IEEE80211_HDRLEN + sizeof(mgmt->u.auth)) {
                wpa_printf(MSG_INFO, "handle_auth - too short payload (len=%lu)",
-@@ -640,6 +646,14 @@ static void handle_auth(struct hostapd_d
+@@ -643,6 +649,14 @@ static void handle_auth(struct hostapd_d
                resp = WLAN_STATUS_UNSPECIFIED_FAILURE;
                goto fail;
        }
        if (res == HOSTAPD_ACL_PENDING) {
                wpa_printf(MSG_DEBUG, "Authentication frame from " MACSTR
                           " waiting for an external authentication",
-@@ -1274,13 +1288,18 @@ static void send_assoc_resp(struct hosta
+@@ -1289,13 +1303,18 @@ static void send_assoc_resp(struct hosta
  
  static void handle_assoc(struct hostapd_data *hapd,
                         const struct ieee80211_mgmt *mgmt, size_t len,
  
        if (len < IEEE80211_HDRLEN + (reassoc ? sizeof(mgmt->u.reassoc_req) :
                                      sizeof(mgmt->u.assoc_req))) {
-@@ -1379,6 +1398,13 @@ static void handle_assoc(struct hostapd_
+@@ -1394,6 +1413,13 @@ static void handle_assoc(struct hostapd_
                goto fail;
        }
  
        sta->capability = capab_info;
        sta->listen_interval = listen_interval;
  
-@@ -1760,7 +1786,7 @@ int ieee802_11_mgmt(struct hostapd_data 
+@@ -1785,7 +1811,7 @@ int ieee802_11_mgmt(struct hostapd_data 
  
  
        if (stype == WLAN_FC_STYPE_PROBE_REQ) {
                return 1;
        }
  
-@@ -1775,17 +1801,17 @@ int ieee802_11_mgmt(struct hostapd_data 
+@@ -1800,17 +1826,17 @@ int ieee802_11_mgmt(struct hostapd_data 
        switch (stype) {
        case WLAN_FC_STYPE_AUTH:
                wpa_printf(MSG_DEBUG, "mgmt::auth");
        case WLAN_FC_STYPE_DISASSOC:
 --- a/src/ap/beacon.c
 +++ b/src/ap/beacon.c
-@@ -498,7 +498,7 @@ static enum ssid_match_result ssid_match
+@@ -513,7 +513,7 @@ static enum ssid_match_result ssid_match
  
  void handle_probe_req(struct hostapd_data *hapd,
                      const struct ieee80211_mgmt *mgmt, size_t len,
  {
        u8 *resp;
        struct ieee802_11_elems elems;
-@@ -506,8 +506,14 @@ void handle_probe_req(struct hostapd_dat
+@@ -521,8 +521,14 @@ void handle_probe_req(struct hostapd_dat
        size_t ie_len;
        struct sta_info *sta = NULL;
        size_t i, resp_len;
  
        ie = mgmt->u.probe_req.variable;
        if (len < IEEE80211_HDRLEN + sizeof(mgmt->u.probe_req))
-@@ -644,6 +650,12 @@ void handle_probe_req(struct hostapd_dat
+@@ -660,6 +666,12 @@ void handle_probe_req(struct hostapd_dat
        }
  #endif /* CONFIG_P2P */