hostapd: remove random pool support - the entropy it gathers is questionable and...
[15.05/openwrt.git] / package / network / services / hostapd / patches / 453-ap_sta_support.patch
index a3dff04..d4b6c1d 100644 (file)
@@ -1,23 +1,26 @@
 --- a/wpa_supplicant/wpa_supplicant_i.h
 +++ b/wpa_supplicant/wpa_supplicant_i.h
-@@ -96,6 +96,8 @@ struct wpa_interface {
-        * receiving of EAPOL frames from an additional interface.
-        */
-       const char *bridge_ifname;
-+
-+      const char *hostapd_ctrl;
- };
+@@ -96,6 +96,11 @@ struct wpa_interface {
+       const char *ifname;
  
- /**
-@@ -306,6 +308,8 @@ struct wpa_supplicant {
+       /**
++       * hostapd_ctrl - path to hostapd control socket for notification
++       */
++      const char *hostapd_ctrl;
++
++      /**
+        * bridge_ifname - Optional bridge interface name
+        *
+        * If the driver interface (ifname) is included in a Linux bridge
+@@ -328,6 +333,8 @@ struct wpa_supplicant {
  #endif /* CONFIG_CTRL_IFACE_DBUS_NEW */
        char bridge_ifname[16];
  
 +      struct wpa_ctrl *hostapd;
 +
        char *confname;
+       char *confanother;
        struct wpa_config *conf;
-       int countermeasures;
 --- a/wpa_supplicant/Makefile
 +++ b/wpa_supplicant/Makefile
 @@ -13,6 +13,10 @@ PKG_CONFIG ?= pkg-config
  -include .config
  -include $(if $(MULTICALL),../hostapd/.config)
  
-@@ -76,6 +80,10 @@ OBJS_c = wpa_cli.o ../src/common/wpa_ctr
+@@ -76,6 +80,8 @@ OBJS_c = wpa_cli.o ../src/common/wpa_ctr
  OBJS_c += ../src/utils/wpa_debug.o
  OBJS_c += ../src/utils/common.o
  
-+ifdef MULTICALL
 +OBJS += ../src/common/wpa_ctrl.o
-+endif
 +
  ifndef CONFIG_OS
  ifdef CONFIG_NATIVE_WINDOWS
  CONFIG_OS=win32
 --- a/wpa_supplicant/wpa_supplicant.c
 +++ b/wpa_supplicant/wpa_supplicant.c
-@@ -107,6 +107,55 @@ extern int wpa_debug_show_keys;
+@@ -109,6 +109,46 @@ extern int wpa_debug_show_keys;
  extern int wpa_debug_timestamp;
  extern struct wpa_driver_ops *wpa_drivers[];
  
-+#ifdef MULTICALL
 +static int hostapd_stop(struct wpa_supplicant *wpa_s)
 +{
 +      const char *cmd = "DOWN";
 +      char *cmd = NULL;
 +      char buf[256];
 +      int len = sizeof(buf);
-+      int channel, hw_mode;
++      enum hostapd_hw_mode hw_mode;
++      u8 channel;
 +      int ret;
 +
 +      if (!bss)
 +              return;
 +
-+      if (bss->freq < 4000) {
-+              hw_mode = HOSTAPD_MODE_IEEE80211G;
-+              channel = (bss->freq - 2407) / 5;
-+      } else {
-+              hw_mode = HOSTAPD_MODE_IEEE80211A;
-+              channel = (bss->freq - 5000) / 5;
-+      }
-+
++      hw_mode = ieee80211_freq_to_chan(bss->freq, &channel);
 +      if (asprintf(&cmd, "UPDATE channel=%d sec_chan=0 hw_mode=%d ieee80211n=%d",
-+                   channel, hw_mode, !!bss->ht_capab) < 0) {
++                   channel, hw_mode, !!bss->ht_capab) < 0)
 +              return -1;
-+      }
 +
 +      ret = wpa_ctrl_request(wpa_s->hostapd, cmd, os_strlen(cmd), buf, &len, NULL);
 +      free(cmd);
 +      }
 +      return 0;
 +}
-+#endif
 +
  /* Configure default/group WEP keys for static WEP */
  int wpa_set_wep_keys(struct wpa_supplicant *wpa_s, struct wpa_ssid *ssid)
  {
-@@ -667,8 +716,16 @@ void wpa_supplicant_set_state(struct wpa
+@@ -676,8 +716,12 @@ void wpa_supplicant_set_state(struct wpa
  #endif /* CONFIG_P2P */
  
                sme_sched_obss_scan(wpa_s, 1);
-+#ifdef MULTICALL
 +              if (wpa_s->hostapd)
 +                      hostapd_reload(wpa_s, wpa_s->current_bss);
-+#endif
        } else if (state == WPA_DISCONNECTED || state == WPA_ASSOCIATING ||
                   state == WPA_ASSOCIATED) {
-+#ifdef MULTICALL
 +              if (wpa_s->hostapd)
 +                      hostapd_stop(wpa_s);
-+#endif
                wpa_s->new_connection = 1;
                wpa_drv_set_operstate(wpa_s, 0);
  #ifndef IEEE8021X_EAPOL
-@@ -2853,6 +2910,21 @@ static int wpa_supplicant_init_iface(str
-               os_strlcpy(wpa_s->bridge_ifname, iface->bridge_ifname,
+@@ -2875,6 +2919,20 @@ static int wpa_supplicant_init_iface(str
                           sizeof(wpa_s->bridge_ifname));
        }
-+#ifdef MULTICALL
 +      if (iface->hostapd_ctrl) {
 +              char *cmd = "DOWN";
 +              char buf[256];
 +              if (hostapd_stop(wpa_s) < 0)
 +                      return -1;
 +      }
-+#endif
++
        /* RSNA Supplicant Key Management - INITIALIZE */
        eapol_sm_notify_portEnabled(wpa_s->eapol, FALSE);
+       eapol_sm_notify_portValid(wpa_s->eapol, FALSE);
 --- a/wpa_supplicant/bss.c
 +++ b/wpa_supplicant/bss.c
 @@ -11,6 +11,7 @@
  
 --- a/wpa_supplicant/main.c
 +++ b/wpa_supplicant/main.c
-@@ -25,7 +25,7 @@ static void usage(void)
-              "usage:\n"
+@@ -27,7 +27,7 @@ static void usage(void)
               "  wpa_supplicant [-BddhKLqqstuvW] [-P<pid file>] "
               "[-g<global ctrl>] \\\n"
+              "        [-G<group>] \\\n"
 -             "        -i<ifname> -c<config file> [-C<ctrl>] [-D<driver>] "
-+             "        -i<ifname> -c<config file> [-C<ctrl>] [-D<driver>] [-H<hostapd path>]"
++             "        -i<ifname> -c<config file> [-C<ctrl>] [-D<driver>] [-H<hostapd path>] "
               "[-p<driver_param>] \\\n"
               "        [-b<br_ifname>] [-f<debug file>] [-e<entropy file>] "
               "\\\n"
-@@ -67,6 +67,7 @@ static void usage(void)
+@@ -72,6 +72,7 @@ static void usage(void)
  #endif /* CONFIG_DEBUG_LINUX_TRACING */
        printf("  -t = include timestamp in debug messages\n"
               "  -h = show this help text\n"
               "  -L = show license (BSD)\n"
               "  -o = override driver parameter for new interfaces\n"
               "  -O = override ctrl_interface parameter for new interfaces\n"
-@@ -155,7 +156,7 @@ int main(int argc, char *argv[])
+@@ -160,7 +161,7 @@ int main(int argc, char *argv[])
  
        for (;;) {
                c = getopt(argc, argv,
--                         "b:Bc:C:D:de:f:g:hi:KLNo:O:p:P:qsTtuvW");
-+                         "b:Bc:C:D:de:f:g:hH:i:KLNo:O:p:P:qsTtuvW");
+-                         "b:Bc:C:D:de:f:g:G:hi:I:KLNo:O:p:P:qsTtuvW");
++                         "b:Bc:C:D:de:f:g:G:hH:i:I:KLNo:O:p:P:qsTtuvW");
                if (c < 0)
                        break;
                switch (c) {
-@@ -199,6 +200,9 @@ int main(int argc, char *argv[])
+@@ -207,6 +208,9 @@ int main(int argc, char *argv[])
                        usage();
                        exitcode = 0;
                        goto out;