mac80211: do not delete linux/*_platform.h, they are touched by patches. instead...
[openwrt.git] / package / mac80211 / patches / 050-compat_firmware.patch
index af7c4fe..602e82d 100644 (file)
@@ -1,23 +1,20 @@
 --- a/compat/Makefile
 +++ b/compat/Makefile
-@@ -1,10 +1,13 @@
+@@ -1,7 +1,10 @@
  obj-m += compat.o
  #compat-objs :=
  
 -obj-$(CONFIG_COMPAT_FIRMWARE_CLASS) += compat_firmware_class.o
- compat-y += main.o
 +ifdef CONFIG_COMPAT_FIRMWARE_CLASS
 +  compat-y += compat_firmware_class.o
 +endif
 +
- # Compat kernel compatibility code
compat-$(CONFIG_COMPAT_KERNEL_2_6_14) += compat-2.6.14.o
- compat-$(CONFIG_COMPAT_KERNEL_2_6_18) += compat-2.6.18.o
+ obj-$(CONFIG_COMPAT_NET_SCH_CODEL) += sch_codel.o
obj-$(CONFIG_COMPAT_NET_SCH_FQ_CODEL) += sch_fq_codel.o
 --- a/compat/compat_firmware_class.c
 +++ b/compat/compat_firmware_class.c
-@@ -741,19 +741,16 @@ request_firmware_nowait(
+@@ -741,19 +741,16 @@ compat_request_firmware_nowait(
        return 0;
  }
  
 -fs_initcall(firmware_class_init);
 -module_exit(firmware_class_exit);
 -
- EXPORT_SYMBOL(release_firmware);
- EXPORT_SYMBOL(request_firmware);
- EXPORT_SYMBOL(request_firmware_nowait);
+ EXPORT_SYMBOL_GPL(release_firmware);
+ EXPORT_SYMBOL_GPL(request_firmware);
+ EXPORT_SYMBOL_GPL(request_firmware_nowait);
 --- a/compat/main.c
 +++ b/compat/main.c
-@@ -32,6 +32,17 @@ module_param(compat_version, charp, 0400
- MODULE_PARM_DESC(compat_version,
-                "Version of the kernel compat backport work");
+@@ -47,6 +47,17 @@ void compat_dependency_symbol(void)
+ EXPORT_SYMBOL_GPL(compat_dependency_symbol);
  
 +#if defined(CONFIG_FW_LOADER) && (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,33))
 +int __init firmware_class_init(void);
 +
  static int __init compat_init(void)
  {
-       /* pm-qos for kernels <= 2.6.24, this is a no-op on newer kernels */
-@@ -46,7 +57,8 @@ static int __init compat_init(void)
-              COMPAT_BASE_TREE " " COMPAT_BASE_TREE_VERSION
-              "\n");
+       compat_pm_qos_power_init();
+@@ -63,7 +74,8 @@ static int __init compat_init(void)
+       printk(KERN_INFO "compat.git: "
+              COMPAT_BASE_TREE "\n");
  
 -        return 0;
 +      firmware_class_init();
@@ -69,7 +66,7 @@
  }
  module_init(compat_init);
  
-@@ -55,7 +67,8 @@ static void __exit compat_exit(void)
+@@ -72,7 +84,8 @@ static void __exit compat_exit(void)
        compat_pm_qos_power_deinit();
        compat_system_workqueue_destroy();