linux-atm: add the kernel include dir to the cflags and move the build dir to $(KERNE...
[openwrt.git] / package / linux-atm / Makefile
index 07484c6..c8a18c3 100644 (file)
@@ -6,6 +6,7 @@
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=linux-atm
 PKG_VERSION:=2.5.1
@@ -46,6 +47,8 @@ define Build/Configure
        touch $(PKG_BUILD_DIR)/stamp-h.in
 endef
 
+TARGET_CFLAGS += -I$(LINUX_DIR)/include
+
 define Build/Compile
        # src/qgen is built with HOSTCC, which does not really like our LDFLAGS
        $(MAKE) -C $(PKG_BUILD_DIR)/src/qgen \