change cp to $(CP)
[openwrt.git] / package / libvorbis / Makefile
index 1777ed8..ec36018 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libvorbis
-PKG_VERSION:=1.1.1
+PKG_VERSION:=1.1.2
 PKG_RELEASE:=1
-PKG_MD5SUM:=b77270c24840af4de54bea5ad1c0b252
+PKG_MD5SUM:=37847626b8e1b53ae79a34714c7b3211
 
 PKG_SOURCE_URL:=http://downloads.xiph.org/releases/vorbis/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -18,7 +18,7 @@ include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,LIBVORBIS,libvorbis,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-# NOTE: check ./toolchain/libmissing
+# NOTE: check ./toolchain/libnotimpl
 # it implements those functions missing from the version of uClibc we're currently using
 # for libvorbis, they are cosf/sinf
 
@@ -28,7 +28,7 @@ $(PKG_BUILD_DIR)/.configured:
                CFLAGS="$(strip $(TARGET_CFLAGS))" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               LIBS="-lm -logg -lmissing" \
+               LIBS="-lm -logg -lnotimpl" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
@@ -70,18 +70,18 @@ $(PKG_BUILD_DIR)/.built:
 
 $(IPKG_LIBVORBIS):
        install -m0755 -d $(IDIR_LIBVORBIS)/usr/lib
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libvorbis.so.* $(IDIR_LIBVORBIS)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbis.so.* $(IDIR_LIBVORBIS)/usr/lib/
        $(RSTRIP) $(IDIR_LIBVORBIS)
        $(IPKG_BUILD) $(IDIR_LIBVORBIS) $(PACKAGE_DIR)
 
 $(STAGING_DIR)/usr/lib/libvorbis.so: $(PKG_BUILD_DIR)/.built
        mkdir -p $(STAGING_DIR)/usr/include
-       cp -fpR $(PKG_INSTALL_DIR)/usr/include/vorbis $(STAGING_DIR)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/vorbis $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libvorbis.a $(STAGING_DIR)/usr/lib/
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libvorbis{,enc,file}.so* $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbis.a $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbis{,enc,file}.so* $(STAGING_DIR)/usr/lib/
        mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/vorbis{,enc,file}.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/vorbis{,enc,file}.pc $(STAGING_DIR)/usr/lib/pkgconfig/
        $(SED) 's,-I$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/vorbis{,enc,file}.pc
        $(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/vorbis{,enc,file}.pc
        touch $@
@@ -95,8 +95,8 @@ uninstall-dev:
                $(STAGING_DIR)/usr/lib/libvorbis{,enc,file}.so* \
                $(STAGING_DIR)/usr/lib/pkgconfig/vorbis{,enc,file}.pc \
 
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev
 
 mostlyclean:
        -$(MAKE) -C $(PKG_BUILD_DIR) clean