ncurses: Fix build of libncursew
[openwrt.git] / package / libs / ncurses / Makefile
index 13c7962..924033f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ncurses
 PKG_VERSION:=5.9
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -91,6 +91,7 @@ endif
 ifeq ($(BUILD_VARIANT),libncursesw)
        CONFIGURE_ARGS += \
                --enable-widec \
+               --includedir="/usr/include/ncursesw" \
                --with-build-cppflags=-D_GNU_SOURCE
 endif
 
@@ -138,7 +139,7 @@ endef
 ifeq ($(BUILD_VARIANT),libncursesw)
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/ncursesw/
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/ncursesw/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/ncursesw/*.h $(1)/usr/include/ncursesw/
 
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{ncurses,panel,menu,form}w.{a,so*} $(1)/usr/lib/