nettle: bump to 3.1
[openwrt.git] / package / libs / ncurses / Makefile
index 9c682ac..3e087f9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,24 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ncurses
-PKG_VERSION:=5.7
-PKG_RELEASE:=5
+PKG_VERSION:=5.9
+PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/ncurses
-PKG_MD5SUM:=cce05daf61a64501ef6cd8da1f727ec6
+PKG_MD5SUM:=8cb9c412e5f2d96bc6f459aa8c6282a1
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=README
 
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 
+PKG_BUILD_DEPENDS:=ncurses/host
+
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 define Package/libncurses
   SECTION:=libs
@@ -55,8 +61,10 @@ CONFIGURE_ARGS += \
        --disable-rpath \
        --without-ada \
        --without-debug \
+       --without-manpages \
        --without-profile \
        --without-progs \
+       --without-tests \
        --disable-big-core \
        --disable-home-terminfo \
        --with-normal \
@@ -64,6 +72,17 @@ CONFIGURE_ARGS += \
        --with-terminfo-dirs=/usr/share/terminfo \
        --with-default-terminfo-dir=/usr/share/terminfo
 
+HOST_CONFIGURE_ARGS += \
+       --without-cxx \
+       --without-cxx-binding \
+       --without-ada \
+       --without-debug \
+       --without-manpages \
+       --without-profile \
+       --without-tests \
+       --without-curses-h
+
+
 ifeq ($(HOST_OS),FreeBSD)
        CONFIGURE_ARGS +=
                --with-terminfo=/usr/share/terminfo.db 
@@ -98,7 +117,7 @@ ifneq ($(HOST_OS),FreeBSD)
                        mv $$$$dir $$$$(echo -ne "\x$$$$dir"); \
                done \
        )
-       for file in a/ansi d/dumb l/linux r/rxvt r/rxvt-unicode s/screen v/vt100 v/vt102 x/xterm x/xterm-color; do \
+       for file in a/ansi d/dumb l/linux r/rxvt r/rxvt-unicode s/screen v/vt100 v/vt102 x/xterm x/xterm-color x/xterm-256color; do \
                $(INSTALL_DIR) $(1)/usr/share/terminfo/`dirname $$$$file`; \
                $(CP) $(PKG_INSTALL_DIR)/usr/share/terminfo/$$$$file \
                        $(1)/usr/share/terminfo/$$$$file; \
@@ -128,7 +147,7 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/ncursesw5-config $(2)/bin/
        $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' -e 's/$$$$INCS //g' \
                $(2)/bin/ncursesw5-config
-       ln -sf $(STAGING_DIR)/host/bin/ncursesw5-config $(1)/usr/bin/ncursesw5-config
+       $(LN) $(2)/bin/ncursesw5-config $(1)/usr/bin/ncursesw5-config
 endef
 else
 define Build/InstallDev
@@ -142,10 +161,21 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/ncurses5-config $(2)/bin/
        $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
                $(2)/bin/ncurses5-config
-       ln -sf $(STAGING_DIR)/host/bin/ncurses5-config $(1)/usr/bin/ncurses5-config
+       $(LN) $(2)/bin/ncurses5-config $(1)/usr/bin/ncurses5-config
 endef
 endif
 
+
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR) libs
+       $(MAKE) -C $(HOST_BUILD_DIR)/progs tic
+endef
+
+define Host/Install
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/progs/tic $(STAGING_DIR_HOST)/bin/tic
+endef
+
+$(eval $(call HostBuild))
 $(eval $(call BuildPackage,terminfo))
 $(eval $(call BuildPackage,libncurses))
 $(eval $(call BuildPackage,libncursesw))