libs/libpcap: update to 1.8.1
[15.05/openwrt.git] / package / libs / libpcap / Makefile
index 24b07c9..234c55c 100644 (file)
@@ -8,17 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libpcap
-PKG_VERSION:=1.3.0
+PKG_VERSION:=1.8.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tcpdump.org/release/
-PKG_MD5SUM:=f78455a92622b7a3c05c58b6ad1cec7e
+PKG_MD5SUM:=3d48f9cd171ff12b0efd9134b52f1447
+PKG_FIXUP:=patch-libtool
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
+PKG_LICENSE:=BSD-3-Clause
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -52,14 +54,16 @@ CONFIGURE_VARS += \
 
 CONFIGURE_ARGS += \
        --enable-shared \
-       --enable-static \
        --disable-yydebug \
-       --with-build-cc="$(HOSTCC)" \
        --with-pcap=linux \
        --without-septel \
        --without-dag \
        --without-libnl \
-       --disable-can
+       --without-snf \
+       --disable-can \
+       --disable-canusb \
+       --disable-dbus \
+       --disable-bluetooth
 
 ifeq ($(CONFIG_IPV6),y)
 CONFIGURE_ARGS += \