libjson-c: rename the libjson binary package to libjson-c, add a new libjson package...
[openwrt.git] / package / libs / libjson-c / Makefile
index cc82df4..3a8a41b 100644 (file)
@@ -27,30 +27,51 @@ include $(INCLUDE_DIR)/package.mk
 
 TARGET_CFLAGS += $(FPIC)
 
-define Package/libjson
+define Package/libjson-c
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=javascript object notation
   URL:=http://oss.metaparadigm.com/json-c/
 endef
 
-define Package/libjson/description
+define Package/libjson-c/description
  This package contains a library for javascript object notation backends.
 endef
 
+define Package/libjson
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+libjson-c
+  TITLE:=javascript object notation (compat library)
+  URL:=http://oss.metaparadigm.com/json-c/
+endef
+
+define Package/libjson/description
+ This package contains a compatibility library for packages that have not
+ been adapted to the json-c library rename yet
+endef
+
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/json $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/json-c $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson.{a,so*} $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson-c.{a,so*} $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/json-c.pc $(1)/usr/lib/pkgconfig/
 endef
 
-define Package/libjson/install
+define Package/libjson-c/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson-c.so.* $(1)/usr/lib/
 endef
 
+define Package/libjson/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libjson-c))
 $(eval $(call BuildPackage,libjson))