libiconv-full: move to trunk and add myself as maintainer
[openwrt.git] / package / libs / libiconv-full / Makefile
diff --git a/package/libs/libiconv-full/Makefile b/package/libs/libiconv-full/Makefile
new file mode 100644 (file)
index 0000000..6ce0589
--- /dev/null
@@ -0,0 +1,88 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libiconv-full
+PKG_VERSION:=1.11.1
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+
+PKG_SOURCE:=libiconv-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/libiconv
+PKG_MD5SUM:=d42b97f6ef5dd0ba4469d520ed732fed
+PKG_BUILD_DIR:=$(BUILD_DIR)/libiconv-$(PKG_VERSION)
+
+PKG_FIXUP:=patch-libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libiconv-full/Default
+  URL:=http://www.gnu.org/software/libiconv/
+  TITLE:=Character set conversion
+endef
+
+define Package/libiconv-full
+  $(call Package/libiconv-full/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE+= library
+endef
+
+define Package/libcharset
+  $(call Package/libiconv-full/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE+= library
+endef
+
+define Package/iconv
+  $(call Package/libiconv-full/Default)
+  DEPENDS:=+libiconv-full +libcharset
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE+= utility
+endef
+
+TARGET_CFLAGS += $(FPIC) -DUSE_DOS
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath \
+       --enable-relocatable
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               install
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/lib/libiconv-full/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/iconv.h $(1)/usr/lib/libiconv-full/include/
+
+       $(INSTALL_DIR) $(1)/usr/lib/libiconv-full/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcharset.{a,so*} $(1)/usr/lib/libiconv-full/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libiconv.{a,so*} $(1)/usr/lib/libiconv-full/lib/
+endef
+
+define Package/libcharset/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcharset.so* $(1)/usr/lib/
+endef
+
+define Package/libiconv-full/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libiconv.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libcharset))
+$(eval $(call BuildPackage,libiconv-full))
+$(eval $(call BuildPackage,iconv))