[package] dnsmasq: Fix DHCP no address on interface warning (#10570)
[openwrt.git] / package / libnl-tiny / Makefile
index 46a7259..37ac26f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnl-tiny
 PKG_VERSION:=0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,6 +28,8 @@ define Build/Prepare
        $(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
@@ -36,9 +38,10 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/include/libnl-tiny
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig $(1)/usr/include/libnl-tiny
        $(CP) $(PKG_BUILD_DIR)/include/* $(1)/usr/include/libnl-tiny
        $(CP) $(PKG_BUILD_DIR)/libnl-tiny.so $(1)/usr/lib/
+       $(CP) ./files/libnl-tiny.pc $(1)/usr/lib/pkgconfig
 endef
 
 define Package/libnl-tiny/install