kernel: build kmod-video-gspca-gl860 and kmod-video-gspca-jeilinj on all kernel versions
[openwrt.git] / package / kernel / modules / video.mk
index 6091989..a7f508b 100644 (file)
@@ -18,24 +18,22 @@ define KernelPackage/video-core
        CONFIG_VIDEO_V4L1=y \
        CONFIG_VIDEO_ALLOW_V4L1=y \
        CONFIG_VIDEO_CAPTURE_DRIVERS=y \
-       CONFIG_V4L_USB_DRIVERS=y 
-endef
-
-define KernelPackage/video-core/2.4
-  FILES:=$(LINUX_DIR)/drivers/media/video/videodev.ko
-  AUTOLOAD:=$(call AutoLoad,60,videodev)
-endef
-
-define KernelPackage/video-core/2.6
+       CONFIG_V4L_USB_DRIVERS=y \
+       CONFIG_V4L_PCI_DRIVERS=y \
+       CONFIG_V4L_PLATFORM_DRIVERS=y \
+       CONFIG_V4L_ISA_PARPORT_DRIVERS=y
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
+  FILES:= \
+       $(LINUX_DIR)/drivers/media/video/v4l2-common.ko \
+       $(LINUX_DIR)/drivers/media/video/videodev.ko
+  AUTOLOAD:=$(call AutoLoad,60, videodev v4l2-common)
+else
   FILES:= \
        $(LINUX_DIR)/drivers/media/video/v4l2-common.ko \
        $(LINUX_DIR)/drivers/media/video/v4l1-compat.ko \
        $(LINUX_DIR)/drivers/media/video/videodev.ko
-  AUTOLOAD:=$(call AutoLoad,60, \
-       v4l1-compat \
-       videodev \
-       v4l2-common \
-  )
+  AUTOLOAD:=$(call AutoLoad,60, v4l1-compat videodev v4l2-common)
+endif
 endef
 
 define KernelPackage/video-core/description
@@ -67,58 +65,6 @@ endef
 $(eval $(call KernelPackage,video-cpia2))
 
 
-define KernelPackage/video-konica
-  TITLE:=Konica USB webcam support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core
-  KCONFIG:=CONFIG_USB_KONICAWC
-  FILES:=$(LINUX_DIR)/drivers/media/video/usbvideo/konicawc.ko
-  AUTOLOAD:=$(call AutoLoad,70,konicawc)
-  $(call AddDepends/video)
-endef
-
-define KernelPackage/video-konica/description
- Kernel support for webcams based on a Konica chipset. This is known to 
- work with the Intel YC76 webcam.
-endef
-
-$(eval $(call KernelPackage,video-konica))
-
-
-define KernelPackage/video-ov511
-  TITLE:=OV511 USB webcam support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core
-  KCONFIG:=CONFIG_VIDEO_OV511
-  FILES:=$(LINUX_DIR)/drivers/media/video/ov511.ko
-  AUTOLOAD:=$(call AutoLoad,70,ov511)
-  $(call AddDepends/video)
-endef
-
-
-define KernelPackage/video-ov511/description
- Kernel modules for supporting OmniVision OV511 USB webcams.
-endef
-
-$(eval $(call KernelPackage,video-ov511))
-
-
-define KernelPackage/video-ovcamchip
-  TITLE:=OV6xxx/OV7xxx Camera Chip support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core
-  KCONFIG:=CONFIG_VIDEO_OVCAMCHIP
-  FILES:=$(LINUX_DIR)/drivers/media/video/ovcamchip/ovcamchip.ko
-  AUTOLOAD:=$(call AutoLoad,70,ovcamchip)
-  $(call AddDepends/video)
-endef
-
-
-define KernelPackage/video-ovcamchip/description
- Kernel modules for supporting OmniVision OV6xxx and OV7xxx series of 
- camera chips.
-endef
-
-$(eval $(call KernelPackage,video-ovcamchip))
-
-
 define KernelPackage/video-sn9c102
   TITLE:=SN9C102 Camera Chip support
   DEPENDS:=@USB_SUPPORT +kmod-usb-core
@@ -302,6 +248,21 @@ endef
 $(eval $(call KernelPackage,video-gspca-ov534))
 
 
+define KernelPackage/video-gspca-ov534-9
+  TITLE:=ov534-9 webcam support
+  KCONFIG:=CONFIG_USB_GSPCA_OV534_9
+  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_ov534_9.ko
+  AUTOLOAD:=$(call AutoLoad,75,gspca_ov534_9)
+  $(call AddDepends/video-gspca)
+endef
+
+define KernelPackage/video-gspca-ov534-9/description
+ The OV534-9 USB Camera Driver (ov534_9) kernel module.
+endef
+
+$(eval $(call KernelPackage,video-gspca-ov534-9))
+
+
 define KernelPackage/video-gspca-pac207
   TITLE:=pac207 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_PAC207
@@ -619,7 +580,6 @@ $(eval $(call KernelPackage,video-gspca-stv06xx))
 
 define KernelPackage/video-gspca-gl860
   TITLE:=gl860 webcam support
-  DEPENDS:=@LINUX_2_6_32
   KCONFIG:=CONFIG_USB_GL860
   FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gl860/gspca_gl860.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_gl860)
@@ -635,7 +595,6 @@ $(eval $(call KernelPackage,video-gspca-gl860))
 
 define KernelPackage/video-gspca-jeilinj
   TITLE:=jeilinj webcam support
-  DEPENDS:=@LINUX_2_6_32
   KCONFIG:=CONFIG_USB_GSPCA_JEILINJ
   FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_jeilinj.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_jeilinj)
@@ -647,3 +606,18 @@ define KernelPackage/video-gspca-jeilinj/description
 endef
 
 $(eval $(call KernelPackage,video-gspca-jeilinj))
+
+
+define KernelPackage/video-gspca-konica
+  TITLE:=konica webcam support
+  KCONFIG:=CONFIG_USB_GSPCA_KONICA
+  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_konica.ko
+  AUTOLOAD:=$(call AutoLoad,75,gspca_konica)
+  $(call AddDepends/video-gspca)
+endef
+
+define KernelPackage/video-gspca-konica/description
+ The Konica USB Camera Driver (konica) kernel module.
+endef
+
+$(eval $(call KernelPackage,video-gspca-konica))