kernel: remove double definition of depends in crypto-mv-cesa and make it look like...
[openwrt.git] / package / kernel / modules / crypto.mk
index 6853050..467db8e 100644 (file)
@@ -427,13 +427,12 @@ endef
 $(eval $(call KernelPackage,crypto-xts))
 
 define KernelPackage/crypto-mv-cesa
-   TITLE:=Marvell crypto engine
-   DEPENDS:=+kmod-crypto-manager
-   KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
-   FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
-   AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
-   SUBMENU:=Cryptographic API modules
-   DEPENDS:=kmod-crypto-core @TARGET_kirkwood||TARGET_orion
+  TITLE:=Marvell crypto engine
+  DEPENDS:=+kmod-crypto-manager @TARGET_kirkwood||TARGET_orion
+  KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
+  FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
+  AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
+  $(call AddDepends/crypto)
 endef
 
 $(eval $(call KernelPackage,crypto-mv-cesa))