kernel: make most modules use AutoProbe
[openwrt.git] / package / kernel / linux / modules / netsupport.mk
index da84ab8..b9e7740 100644 (file)
@@ -521,7 +521,6 @@ define KernelPackage/slhc
   DEPENDS:=+kmod-lib-crc-ccitt
   KCONFIG:=CONFIG_SLHC
   FILES:=$(LINUX_DIR)/drivers/net/slip/slhc.ko
-  AUTOLOAD:=$(call AutoLoad,29,slhc)
 endef
 
 $(eval $(call KernelPackage,slhc))
@@ -537,7 +536,6 @@ define KernelPackage/ppp
   FILES:= \
        $(LINUX_DIR)/drivers/net/ppp/ppp_async.ko \
        $(LINUX_DIR)/drivers/net/ppp/ppp_generic.ko
-  AUTOLOAD:=$(call AutoLoad,30,ppp_generic ppp_async)
 endef
 
 define KernelPackage/ppp/description
@@ -569,7 +567,6 @@ define KernelPackage/pppox
   DEPENDS:=kmod-ppp
   KCONFIG:=CONFIG_PPPOE
   FILES:=$(LINUX_DIR)/drivers/net/ppp/pppox.ko
-  AUTOLOAD:=$(call AutoLoad,40,pppox)
 endef
 
 define KernelPackage/pppox/description
@@ -585,7 +582,7 @@ define KernelPackage/pppoe
   DEPENDS:=kmod-ppp +kmod-pppox
   KCONFIG:=CONFIG_PPPOE
   FILES:=$(LINUX_DIR)/drivers/net/ppp/pppoe.ko
-  AUTOLOAD:=$(call AutoLoad,41,pppoe)
+  AUTOLOAD:=$(call AutoProbe,pppoe)
 endef
 
 define KernelPackage/pppoe/description
@@ -617,7 +614,7 @@ define KernelPackage/pptp
   DEPENDS:=kmod-ppp +kmod-gre +kmod-pppox
   KCONFIG:=CONFIG_PPTP
   FILES:=$(LINUX_DIR)/drivers/net/ppp/pptp.ko
-  AUTOLOAD:=$(call AutoLoad,41,pptp)
+  AUTOLOAD:=$(call AutoProbe,pptp)
 endef
 
 $(eval $(call KernelPackage,pptp))
@@ -629,7 +626,7 @@ define KernelPackage/pppol2tp
   DEPENDS:=kmod-ppp +kmod-pppox +kmod-l2tp
   KCONFIG:=CONFIG_PPPOL2TP
   FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ppp.ko
-  AUTOLOAD:=$(call AutoLoad,41,l2tp_ppp)
+  AUTOLOAD:=$(call AutoProbe,l2tp_ppp)
 endef
 
 define KernelPackage/pppol2tp/description
@@ -645,7 +642,7 @@ define KernelPackage/ipoa
   DEPENDS:=kmod-atm
   KCONFIG:=CONFIG_ATM_CLIP
   FILES:=$(LINUX_DIR)/net/atm/clip.ko
-  AUTOLOAD:=$(call AutoLoad,40,clip)
+  AUTOLOAD:=$(call AutoProbe,clip)
 endef
 
 define KernelPackage/ipoa/description
@@ -663,7 +660,7 @@ define KernelPackage/mppe
        CONFIG_PPP_MPPE_MPPC \
        CONFIG_PPP_MPPE
   FILES:=$(LINUX_DIR)/drivers/net/ppp/ppp_mppe.ko
-  AUTOLOAD:=$(call AutoLoad,31,ppp_mppe)
+  AUTOLOAD:=$(call AutoProbe,ppp_mppe)
 endef
 
 define KernelPackage/mppe/description