linux: convert CompareKernelPatchVer to version tagged symbols
[openwrt.git] / package / kernel / linux / modules / i2c.mk
index 8fed494..d4effee 100644 (file)
@@ -24,10 +24,8 @@ I2C_CORE_MODULES:= \
   CONFIG_I2C:drivers/i2c/i2c-core \
   CONFIG_I2C_CHARDEV:drivers/i2c/i2c-dev
 
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.12.0)),1)
-  ifeq ($(CONFIG_OF),y)
-    I2C_CORE_MODULES+=CONFIG_OF_I2C:drivers/of/of_i2c
-  endif
+ifeq ($(CONFIG_OF),y)
+  I2C_CORE_MODULES+=CONFIG_OF_I2C:drivers/of/of_i2c@lt3.12
 endif
 
 define KernelPackage/i2c-core