linux: don't break kmod-fs-nfs for Kernels < 3.6.x
[openwrt.git] / package / kernel / linux / modules / fs.mk
index 92feb6c..867117f 100644 (file)
@@ -16,7 +16,7 @@ define KernelPackage/fs-autofs4
 endef
 
 define KernelPackage/fs-autofs4/description
 Kernel module for AutoFS4 support
+ Kernel module for AutoFS4 support
 endef
 
 $(eval $(call KernelPackage,fs-autofs4))
@@ -25,7 +25,7 @@ $(eval $(call KernelPackage,fs-autofs4))
 define KernelPackage/fs-btrfs
   SUBMENU:=$(FS_MENU)
   TITLE:=BTRFS filesystem support
-  DEPENDS:=+kmod-lib-crc32c +kmod-lib-lzo +kmod-lib-zlib +(LINUX_3_9||LINUX_3_10):kmod-lib-raid6 +(LINUX_3_9||LINUX_3_10):kmod-lib-xor
+  DEPENDS:=+kmod-lib-crc32c +kmod-lib-lzo +kmod-lib-zlib +(LINUX_3_9||LINUX_3_10||LINUX_3_12):kmod-lib-raid6 +(LINUX_3_9||LINUX_3_10||LINUX_3_12):kmod-lib-xor
   KCONFIG:=\
        CONFIG_BTRFS_FS \
        CONFIG_BTRFS_FS_POSIX_ACL=n \
@@ -36,7 +36,7 @@ define KernelPackage/fs-btrfs
 endef
 
 define KernelPackage/fs-btrfs/description
 Kernel module for BTRFS support
+ Kernel module for BTRFS support
 endef
 
 $(eval $(call KernelPackage,fs-btrfs))
@@ -90,7 +90,7 @@ define KernelPackage/fs-exportfs
   TITLE:=exportfs kernel server support
   KCONFIG:=CONFIG_EXPORTFS
   FILES=$(LINUX_DIR)/fs/exportfs/exportfs.ko
-  AUTOLOAD:=$(call AutoLoad,20,exportfs)
+  AUTOLOAD:=$(call AutoLoad,20,exportfs,1)
 endef
 
 define KernelPackage/fs-exportfs/description
@@ -225,9 +225,15 @@ define KernelPackage/fs-nfs
        CONFIG_NFS_FS \
        CONFIG_NFS_USE_LEGACY_DNS=n \
        CONFIG_NFS_USE_NEW_IDMAPPER=n
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.6.0)),1)
+  FILES:= \
+       $(LINUX_DIR)/fs/nfs/nfs.ko \
+       $(LINUX_DIR)/fs/nfs/nfsv3.ko
+else
   FILES:= \
        $(LINUX_DIR)/fs/nfs/nfs.ko
-  AUTOLOAD:=$(call AutoLoad,40,nfs)
+endif
+  AUTOLOAD:=$(call AutoLoad,40,nfs nfsv3)
 endef
 
 define KernelPackage/fs-nfs/description