kernel: watchdog modules should be loaded on boot
[openwrt.git] / package / kernel / linux / modules / 001-depends.mk
index d0ad083..806c3dc 100644 (file)
@@ -5,19 +5,6 @@
 # See /LICENSE for more information.
 #
 
-define AddDepends/crc16
-  DEPENDS+= +kmod-lib-crc16 $(1)
-endef
-
-define AddDepends/hid
-  DEPENDS+= +kmod-hid $(1)
-endef
-
-define AddDepends/input
-  DEPENDS+= +kmod-input-core $(1)
-endef
-
-
 define AddDepends/nls
   DEPENDS+= +kmod-nls-base $(foreach cp,$(1),+kmod-nls-$(cp))
 endef
@@ -25,8 +12,3 @@ endef
 define AddDepends/rfkill
   DEPENDS+= +USE_RFKILL:kmod-rfkill $(1)
 endef
-
-
-define AddDepends/rtc
-  DEPENDS+= @RTC_SUPPORT $(1)
-endef