precompile ppp active filter (reduces libpcap overhead to only a few k), enable by...
[openwrt.git] / package / iptraf / Makefile
index 3837ec8..c5ae8ea 100644 (file)
@@ -1,9 +1,11 @@
+# $Id$
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iptraf
 PKG_VERSION:=2.7.0
 PKG_RELEASE:=1
-PKG_MD5SUM:=
+PKG_MD5SUM:=7ff0bc933a0a57a4ca9e2b0443307539
 
 PKG_SOURCE_URL:=ftp://iptraf.seul.org/pub/iptraf/ \
        ftp://the.wiretapped.net/pub/security/network-monitoring/iptraf/
@@ -17,10 +19,10 @@ include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,IPTRAF,iptraf,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/.configured:
        touch $@
 
-$(PKG_BUILD_DIR)/.built:
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
        $(MAKE) -C $(PKG_BUILD_DIR)/src \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \