revert to using *_ifnames internally, too many problems with firewall, ppp, etc....
[openwrt.git] / package / ipsec-tools / Makefile
index 9e14b40..3548590 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
@@ -12,12 +18,15 @@ PKG_SOURCE_URL:=@SF/ipsec-tools
 PKG_MD5SUM:=d0242a943c82c0cbf28005966ff35e21
 PKG_CAT:=bzcat
 
-include $(TOPDIR)/package/rules.mk
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 define Package/ipsec-tools
 SECTION:=base
 CATEGORY:=Network
-DEFAULT:=y
+DEPENDS:=@LINUX_2_6 +libopenssl
 TITLE:=IPsec management tools
 DESCRIPTION:=IPsec management tools
 URL:=http://ipsec-tools.sourceforge.net/
@@ -63,16 +72,22 @@ define Build/Configure
                        --with-openssl="$(STAGING_DIR)/usr" \
                        --without-libradius \
                        --without-libpam \
+                       --enable-dpd \
+                       --enable-natt \
        );
 endef
 
+define Build/Compile
+       $(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" all install)
+endef
+
 define Package/ipsec-tools/install
        install -d -m0755 $(1)/etc
+       install -m0600 $(PKG_BUILD_DIR)/src/racoon/samples/racoon.conf $(1)/etc/
        install -d -m0755 $(1)/usr/lib/
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/src/racoon/samples/racoon.conf $(1)/etc/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libipsec.so.* $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libracoon.so.* $(1)/usr/lib/
+       install -d -m0755 $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/plainrsa-gen $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/racoon $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/racoonctl $(1)/usr/sbin/