[package] busybox: update to v1.15.3
[openwrt.git] / package / busybox / Makefile
index 3a04637..43da0a4 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.11.3
-PKG_RELEASE:=6
+PKG_VERSION:=1.15.3
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
-PKG_MD5SUM:=4355ad8bb57ce3b39ad827566c1a6da3
+PKG_MD5SUM:=6059ac9456de6fb18dc8ee4cd0ec9240
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -59,6 +59,10 @@ define Build/Configure
                oldconfig
 endef
 
+ifdef CONFIG_GCC_VERSION_LLVM
+  TARGET_CFLAGS += -fnested-functions
+endif
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \