[package] broadcom-wl:
[openwrt.git] / package / broadcom-wl / patches / 002-ctype.patch
diff --git a/package/broadcom-wl/patches/002-ctype.patch b/package/broadcom-wl/patches/002-ctype.patch
deleted file mode 100644 (file)
index 16d13df..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/shared/Makefile
-+++ b/shared/Makefile
-@@ -19,7 +19,7 @@ LDFLAGS += -L.
- AR=ar
- RANLIB=ranlib
--OBJS := shutils.o wl.o wl_linux.o linux_timer.o
-+OBJS := shutils.o wl.o wl_linux.o linux_timer.o ctype.o
- all: libshared.a
- clean:
---- /dev/null
-+++ b/shared/ctype.c
-@@ -0,0 +1,16 @@
-+#include <features.h>
-+
-+#ifndef __UCLIBC__
-+extern void **__ctype_b_loc();
-+extern void **__ctype_tolower_loc();
-+
-+void *__ctype_b;
-+void *__ctype_tolower;
-+
-+static void init(void) __attribute__((constructor));
-+static void init(void)
-+{
-+    __ctype_b = *__ctype_b_loc();
-+    __ctype_tolower = *__ctype_tolower_loc();
-+}
-+#endif