uboot-oxnas: bump to U-Boot 2014.10
[15.05/openwrt.git] / package / boot / uboot-oxnas / patches / 300-oxnas-target.patch
index cfe918d..44e5842 100644 (file)
@@ -8,20 +8,6 @@
  #define MACH_TYPE_MICRO9M              1169
  #define MACH_TYPE_BUG                  1179
  #define MACH_TYPE_AT91SAM9263EK        1202
---- a/boards.cfg
-+++ b/boards.cfg
-@@ -57,6 +57,11 @@ Active  arm         arm1136        mx35
- Active  arm         arm1136        mx35        -               woodburn            woodburn_sd                          woodburn_sd:IMX_CONFIG=board/woodburn/imximage.cfg                                                                                -
- Active  arm         arm1136        mx35        CarMediaLab     -                   flea3                                -                                                                                                                                 Stefano Babic <sbabic@denx.de>
- Active  arm         arm1136        mx35        freescale       -                   mx35pdk                              -                                                                                                                                 Stefano Babic <sbabic@denx.de>
-+Active  arm         arm1136        nas782x     -               -                   ox820                                -                                                                                                                                 -
-+Active  arm         arm1136        nas782x     -               nas782x             ox820_sata                           ox820:BOOT_FROM_SATA                                                                                                              -
-+Active  arm         arm1136        nas782x     -               nas782x             ox820_fat                            ox820:BOOT_FROM_SATA,BOOT_FROM_FAT
-+Active  arm         arm1136        nas782x     -               nas782x             ox820_ext4                           ox820:BOOT_FROM_SATA,BOOT_FROM_EXT4                                                                                               -
-+Active  arm         arm1136        nas782x     -               nas782x             ox820_nand                           ox820:BOOT_FROM_NAND                                                                                                              -
- Active  arm         arm1176        bcm2835     raspberrypi     rpi_b               rpi_b                                -                                                                                                                                 Stephen Warren <swarren@wwwdotorg.org>
- Active  arm         arm1176        tnetv107x   ti              tnetv107xevm        tnetv107x_evm                        -                                                                                                                                 Chan-Taek Park <c-park@ti.com>
- Active  arm         arm720t        -           armltd          integrator          integratorap_cm720t                  integratorap:CM720T                                                                                                               Linus Walleij <linus.walleij@linaro.org>
 --- a/drivers/block/Makefile
 +++ b/drivers/block/Makefile
 @@ -21,3 +21,4 @@ obj-$(CONFIG_IDE_SIL680) += sil680.o
  obj-$(CONFIG_SCSI_SYM53C8XX) += sym53c8xx.o
  obj-$(CONFIG_SYSTEMACE) += systemace.o
 +obj-$(CONFIG_IDE_PLX) += plxsata_ide.o
---- a/drivers/serial/serial_ns16550.c
-+++ b/drivers/serial/serial_ns16550.c
-@@ -135,6 +135,14 @@ static int calc_divisor (NS16550_t port)
-       }
- #endif
-+#ifdef CONFIG_OX820
-+      {
-+              /* with additional 3 bit fractional */
-+              u32 div = (CONFIG_SYS_NS16550_CLK + gd->baudrate) / (gd->baudrate * 2);
-+              port->reg9 = (div & 7) << 5;
-+              return (div >> 3);
-+      }
-+#endif
- #define MODE_X_DIV 16
-       /* Compute divisor value. Normally, we should simply return:
-        *   CONFIG_SYS_NS16550_CLK) / MODE_X_DIV / gd->baudrate
 --- a/drivers/usb/host/Makefile
 +++ b/drivers/usb/host/Makefile
-@@ -32,6 +32,7 @@ obj-$(CONFIG_USB_EHCI_MX6) += ehci-mx6.o
+@@ -33,6 +33,7 @@ obj-$(CONFIG_USB_EHCI_MX6) += ehci-mx6.o
  obj-$(CONFIG_USB_EHCI_OMAP) += ehci-omap.o
  obj-$(CONFIG_USB_EHCI_PPC4XX) += ehci-ppc4xx.o
  obj-$(CONFIG_USB_EHCI_MARVELL) += ehci-marvell.o
 +obj-$(CONFIG_USB_EHCI_OXNAS) += ehci-oxnas.o
  obj-$(CONFIG_USB_EHCI_PCI) += ehci-pci.o
  obj-$(CONFIG_USB_EHCI_SPEAR) += ehci-spear.o
- obj-$(CONFIG_USB_EHCI_TEGRA) += ehci-tegra.o
---- a/spl/Makefile
-+++ b/spl/Makefile
-@@ -207,8 +207,13 @@ cmd_objcopy = $(OBJCOPY) $(OBJCOPYFLAGS)
- OBJCOPYFLAGS_$(SPL_BIN).bin = $(SPL_OBJCFLAGS) -O binary
-+ifdef CONFIG_OX820
- $(obj)/$(SPL_BIN).bin: $(obj)/$(SPL_BIN) FORCE
-       $(call if_changed,objcopy)
-+      $(OBJTREE)/tools/mkox820crc $@
-+else
-+      $(call if_changed,objcopy)
-+endef
- LDFLAGS_$(SPL_BIN) += -T u-boot-spl.lds $(LDFLAGS_FINAL)
- ifneq ($(CONFIG_SPL_TEXT_BASE),)
+ obj-$(CONFIG_USB_EHCI_SUNXI) += ehci-sunxi.o
 --- a/tools/.gitignore
 +++ b/tools/.gitignore
-@@ -7,6 +7,7 @@
+@@ -9,6 +9,7 @@
  /mkenvimage
  /mkimage
  /mkexynosspl
 +/mkox820crc
  /mpc86x_clk
  /mxsboot
- /ncb
+ /mksunxiboot
 --- a/tools/Makefile
 +++ b/tools/Makefile
-@@ -131,6 +131,12 @@ hostprogs-$(CONFIG_KIRKWOOD) += kwboot$(
- hostprogs-y += proftool$(SFX)
- hostprogs-$(CONFIG_STATIC_RELA) += relocate-rela$(SFX)
+@@ -143,6 +143,12 @@ hostprogs-$(CONFIG_KIRKWOOD) += kwboot
+ hostprogs-y += proftool
+ hostprogs-$(CONFIG_STATIC_RELA) += relocate-rela
  
 +
 +hostprogs-$(CONFIG_OX820) += mkox820crc$(SFX)
 +
-+mkox820crc$(SFX)-objs := mkox820crc.o crc32.o
++mkox820crc$(SFX)-objs := mkox820crc.o lib/crc32.o
 +
 +
  # We build some files with extra pedantic flags to try to minimize things
  # that won't build on some weird host compiler -- though there are lots of
  # exceptions for files that aren't complaint.
+--- a/drivers/serial/ns16550.c
++++ b/drivers/serial/ns16550.c
+@@ -118,6 +118,14 @@ int ns16550_calc_divisor(NS16550_t port,
+       }
+       port->osc_12m_sel = 0;                  /* clear if previsouly set */
+ #endif
++#ifdef CONFIG_OX820
++      {
++              /* with additional 3 bit fractional */
++              u32 div = (CONFIG_SYS_NS16550_CLK + baudrate) / (baudrate * 2);
++              port->reg9 = (div & 7) << 5;
++              return (div >> 3);
++      }
++#endif
+       return DIV_ROUND_CLOSEST(clock, mode_x_div * baudrate);
+ }
+--- a/scripts/Makefile.spl
++++ b/scripts/Makefile.spl
+@@ -202,6 +202,9 @@ OBJCOPYFLAGS_$(SPL_BIN).bin = $(SPL_OBJC
+ $(obj)/$(SPL_BIN).bin: $(obj)/$(SPL_BIN) FORCE
+       $(call if_changed,objcopy)
++ifdef CONFIG_OX820
++      $(OBJTREE)/tools/mkox820crc $@
++endef
+ LDFLAGS_$(SPL_BIN) += -T u-boot-spl.lds $(LDFLAGS_FINAL)
+ ifneq ($(CONFIG_SPL_TEXT_BASE),)
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -488,6 +488,9 @@ config TARGET_BALLOON3
+ config TARGET_H2200
+       bool "Support h2200"
++config TARGET_OX820
++      bool "Support ox820"
++
+ config TARGET_PALMLD
+       bool "Support palmld"
+@@ -650,6 +653,7 @@ source "board/logicpd/imx27lite/Kconfig"
+ source "board/logicpd/imx31_litekit/Kconfig"
+ source "board/mpl/vcma9/Kconfig"
+ source "board/olimex/mx23_olinuxino/Kconfig"
++source "board/ox820/Kconfig"
+ source "board/palmld/Kconfig"
+ source "board/palmtc/Kconfig"
+ source "board/palmtreo680/Kconfig"