linux/crypto: Add echainiv module provided by 4.4 kernels
[openwrt.git] / package / boot / uboot-imx6 / Makefile
index 0c989f3..1e92623 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=u-boot
-PKG_VERSION:=2013.10
+PKG_VERSION:=2014.04
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -16,7 +16,9 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://mirror2.openwrt.org/sources \
        ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=a076a044b64371edc52f7e562b13f6b2
+PKG_MD5SUM:=6d2116d1385a66e9a59742caa9d62a54
+
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,6 +28,10 @@ define uboot/Default
   IMAGE:=
 endef
 
+define uboot/mx6qsabresd
+  TITLE:=U-Boot for SABRE i.MX6Quad board
+endef
+
 define uboot/nitrogen6dl
   TITLE:=U-Boot for Nitrogen6x i.MX6Dual-Lite 1GB board
 endef
@@ -63,6 +69,7 @@ define uboot/wandboard_solo
 endef
 
 UBOOTS := \
+       mx6qsabresd \
        nitrogen6dl \
        nitrogen6dl2g \
        nitrogen6q \
@@ -98,11 +105,13 @@ UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin
 endif
 
 define Build/Configure
-       $(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
+       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
+               $(UBOOT_CONFIG)_config
 endef
 
 define Build/Compile
-       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) CROSS_COMPILE=$(TARGET_CROSS)
+       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
+               CROSS_COMPILE=$(TARGET_CROSS)
 endef
 
 define Package/uboot/install/default