fix ar7 compile
[openwrt.git] / package / ar7-atm / patches / 100-compile_fix.patch
index 45ac1b1..bd081c4 100644 (file)
@@ -89,7 +89,7 @@ diff -urN sangam_atm-07.01.00.10/Makefile sangam-atm-0.3/Makefile
 +#EXTRA_CFLAGS += -DEL -I. -DPOST_SILICON -DCOMMON_NSP -DCONFIG_LED_MODULE -DDEREGISTER_LED -DNO_ACT
 +EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
 +obj-$(CONFIG_SANGAM_ATM) := tiatm.o
-+tiatm-objs += tn7atm.o tn7dsl.o tn7sar.o dsl_hal_api.o dsl_hal_support.o cpsar.o aal5sar.o
++tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o
 diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
 --- sangam_atm-07.01.00.10/tn7atm.c    2006-10-26 16:48:52.000000000 +0200
 +++ sangam-atm-0.3/tn7atm.c    2007-04-18 15:34:05.000000000 +0200
@@ -691,3 +691,17 @@ diff -urN sangam_atm-07.01.00.10/tn7sar.c sangam-atm-0.3/tn7sar.c
  #include <linux/proc_fs.h>
  #include <linux/string.h>
  #include <linux/ctype.h>
+
+diff -ur atm.old/tn7dsl.c atm.dev/tn7dsl.c
+--- atm.old/tn7dsl.c   2007-05-24 17:36:33.865636000 +0200
++++ atm.dev/tn7dsl.c   2007-05-24 17:41:32.094298496 +0200
+@@ -3430,8 +3430,7 @@
+   if (initialized == 1)
+     return;
+-  dslmod_sysctl_header = register_sysctl_table(dslmod_root_table, 1);
+-  dslmod_root_table->child->de->owner = THIS_MODULE;
++  dslmod_sysctl_header = register_sysctl_table(dslmod_root_table);
+   /*
+    * set the defaults