[packages] quagga: Do not try to start 'watchquagga' if it is not available
[packages.git] / net / wifidog / Makefile
index 9fdc0fe..72bf1a6 100644 (file)
@@ -4,19 +4,19 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wifidog
-PKG_VERSION:=1.1.4
+PKG_VERSION:=20090925
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= @SF/$(PKG_NAME)
-PKG_MD5SUM:=daa4f492dd6acafe0a7127d07633aca5
+PKG_MD5SUM:=e3ecacba67a91b6ea3c1072ba6c5a0b4
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,15 +24,15 @@ define Package/wifidog
   SUBMENU:=Captive Portals
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+iptables-mod-extra +iptables-mod-ipopt +iptables-mod-nat +libpthread
+  DEPENDS:=+iptables-mod-extra +iptables-mod-ipopt +kmod-ipt-nat +iptables-mod-nat-extra +libpthread
   TITLE:=A wireless captive portal solution
   URL:=http://www.wifidog.org
 endef
 
 define Package/wifidog/description
-       The Wifidog project is a complete and embeddable captive 
-       portal solution for wireless community groups or individuals 
-       who wish to open a free Hotspot while still preventing abuse 
+       The Wifidog project is a complete and embeddable captive
+       portal solution for wireless community groups or individuals
+       who wish to open a free Hotspot while still preventing abuse
        of their Internet connection.
 endef
 
@@ -40,10 +40,6 @@ define Package/wifidog/conffiles
 /etc/wifidog.conf
 endef
 
-MAKE_FLAGS += \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       all install
-       
 define Package/wifidog/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/init.d/wifidog $(1)/usr/bin/wifidog-init
@@ -53,6 +49,7 @@ define Package/wifidog/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libhttpd.so* $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/wifidog.conf $(1)/etc/
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/wifidog-msg.html $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/wifidog
 endef