[packages_10.03.2] radsecproxy: merge r30360
[10.03/packages.git] / net / radsecproxy / Makefile
index e1b0619..65b7217 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radsecproxy
-PKG_VERSION:=1.4.2
-PKG_RELEASE:=1
+PKG_VERSION:=1.5
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://software.uninett.no/radsecproxy/
-PKG_MD5SUM:=ccdff609c72c0862235b9119323345a8
+PKG_MD5SUM:=c65742a1b471c572ca7f6d11000d41f5
 
 PKG_INSTALL:=1
 
@@ -35,6 +35,11 @@ endef
 CONFIGURE_ARGS+= \
        --with-ssl="$(STAGING_DIR)/usr"
 
+#TARGET_CFLAGS += -ansi
+#TARGET_CFLAGS += -std=c99
+TARGET_CFLAGS += -Wno-long-long
+
+
 define Package/radsecproxy/install
        $(INSTALL_DIR) $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/radsecproxy $(1)/usr/sbin/
@@ -44,5 +49,9 @@ define Package/radsecproxy/install
        $(INSTALL_BIN) ./files/radsecproxy.init $(1)/etc/init.d/radsecproxy
 endef
 
+define Package/radsecproxy/conffiles
+/etc/radsecproxy.conf
+endef
+
 $(eval $(call BuildPackage,radsecproxy))