FreeSWITCH: git HASH e3e267f46249abf714dd596dc89e545fd844aaee
[feed/telephony.git] / net / freeswitch / patches / 0000010-configure_ac.patch
index f490b99..b888afc 100644 (file)
@@ -1,15 +1,34 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -360,7 +360,7 @@ elif test "x${ax_cv_c_compiler_vendor}"
+@@ -229,13 +229,16 @@ AX_COMPILER_VENDOR
+ if test "x${cross_compiling}" = "xyes"; then
+     CC_FOR_BUILD=${CC_FOR_BUILD-gcc}
+     case "$host" in
+-       arm*-linux-gnueabi*|arm*-*-linux-gnueabi*)
++       arm*-linux-gnueabi*|arm*-*-linux-*)
+               # spandsp modem
+               ac_cv_file__dev_ptmx=yes
+               # libjs
+               export ac_cv_va_copy=yes
++              # sofia-sip
++              export ac_cv_dev_urandom=yes
+               # srtp
+               export ac_cv_file__dev_urandom=yes
++              export ac_cv_file___dev_urandom_=yes
+               # rpl_malloc
+               export ac_cv_func_realloc_0_nonnull=yes
+               export ac_cv_func_malloc_0_nonnull=yes
+@@ -378,9 +381,6 @@ elif test "x${ax_cv_c_compiler_vendor}"
  elif test "x${ax_cv_c_compiler_vendor}" = "xgnu" ; then
      APR_ADDTO(SWITCH_AM_CFLAGS, -fPIC)
      APR_ADDTO(SWITCH_AM_CXXFLAGS, -fPIC)
--    APR_ADDTO(SWITCH_AM_CFLAGS, -Werror)
-+#    APR_ADDTO(SWITCH_AM_CFLAGS, -Werror)
+-    if test "$ac_cv_gcc_supports_w_no_unused_result" = yes; then
+-      APR_ADDTO(SWITCH_AM_CFLAGS, -Werror)
+-    fi
      if test "${enable_64}" = "yes"; then
        case "$host" in
               *darwin12.*|*darwin11.*|*darwin10.*|*darwin9.*|*darwin8.*)
-@@ -811,7 +811,6 @@ AC_CHECK_LIB(pthread, pthread_setschedpa
+@@ -839,7 +839,6 @@ AC_CHECK_LIB(pthread, pthread_setschedpa
  
  AC_CHECK_FUNC(socket, , AC_CHECK_LIB(socket, socket))
  
  AC_CHECK_LIB(util, openpty, [AC_DEFINE(HAVE_OPENPTY, 1, [Define if you have openpty()])])
  
  AC_CHECK_MEMBERS([struct tm.tm_gmtoff],,,[
-@@ -1241,36 +1240,43 @@ AM_CONDITIONAL([HAVE_MYSQL],[test "$foun
+@@ -1163,14 +1162,14 @@ case $host in
+        ;;
+ esac
+-if ! (test -x "$PKG_CONFIG" || test -x "$(which pkg-config)"); then
+-  AC_MSG_ERROR([You need to install pkg-config to configure FreeSWITCH.])
++if ! test -x "${STAGING_DIR}/../host/bin/pkg-config"; then
++  AC_MSG_ERROR([Missing tools/pkg-config package needed to configure FreeSWITCH.])
+ fi
+-# temporary workaround for Debian libldns-dev package bug
+-if test "$cross_compiling" != "yes" && test -f /usr/lib/pkg-config/libldns.pc; then
+-  path_push_unique PKG_CONFIG_PATH /usr/lib/pkg-config
+-fi
++#
++# Workaround for OpenWRT pkg-config
++#
++path_push_unique PKG_CONFIG_PATH ${STAGING_DIR}/usr/lib/pkg-config
+ module_enabled() {
+   grep -v -e "\#" -e "^\$" modules.conf | sed -e "s|^.*/||" | grep "^${1}\$" >/dev/null
+@@ -1191,7 +1190,7 @@ PKG_CHECK_MODULES([LDNS], [libldns >= 1.
+   AC_CHECK_LIB([ldns], [ldns_str2rdf_a], [LDNS_LIBS=-lldns])
+   AS_IF([test -z "$LDNS_LIBS"],[
+     if module_enabled mod_enum; then
+-      AC_MSG_ERROR([You need to either install libldns-dev or disable mod_enum in modules.conf])
++      AC_MSG_ERROR([You need to either install libldns or disable mod_enum in modules.conf])
+     else
+       AC_MSG_RESULT([no]); AM_CONDITIONAL([HAVE_LDNS],[false])
+     fi],[
+@@ -1269,21 +1268,21 @@ AM_CONDITIONAL([HAVE_MYSQL],[test "$foun
  # perl checks
  #
  
 -   PERL_LDFLAGS="`$PERL -MExtUtils::Embed -e ldopts| sed -e 's|-arch x86_64 -arch i386||'`"
 -   PERL_INC="`$PERL -MExtUtils::Embed -e perl_inc`"
 +   PERL="${STAGING_DIR}/../host/usr/bin/perl"
-+   #PERL_SITEDIR="`${PERL} -MConfig -e 'print $Config{installarchlib}'`"
 +   PERL_SITELIB="/usr/lib/perl5/5.20"
 +   PERL_SITEDIR="${STAGING_DIR}${PERL_SITELIB}"
 +   PERL_COREDIR="${PERL_SITEDIR}/CORE"
 +   PERL_INC="-I${PERL_COREDIR}"
-+   #PERL_CFLAGS="-w -DMULTIPLICITY `${PERL} -MExtUtils::Embed -e ccopts` -DEMBED_PERL"
 +   PERL_CFLAGS="-w -DMULTIPLICITY -fwrapv -fno-strict-aliasing -pipe -fstack-protector ${PERL_INC} -DEMBED_PERL"
 +   PERL_LIBDIR="-L${PERL_COREDIR}"
-+   #PERL_LIBS="${PERL_LIBDIR} -lpthread `${PERL} -MConfig -e 'print $Config{libs}' | sed -e 's| -lgdbm_compat||g'` "
-+   #PERL_LDFLAGS="`${PERL} -MExtUtils::Embed -e ldopts | sed -e 's| -lgdbm_compat||g'` "
 +   PERL_LIBS="-lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc "
-+   PERL_LDFLAGS="${PERL_LIBDIR} -lpthread -lperl -lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc -lrt "
++   PERL_LDFLAGS="${LDFLAGS} -lpthread ${PERL_LIBS}"
  
     save_CFLAGS="$CFLAGS"
 -   CFLAGS="$PERL_CFLAGS"
     AC_CHECK_HEADER([EXTERN.h], [ac_cv_have_EXTERN_h=yes], [ac_cv_have_EXTERN_h=no], [[#include <EXTERN.h>
  # include <perl.h>]])
     CFLAGS="$save_CFLAGS"
+@@ -1291,14 +1290,17 @@ if test "x$ac_cv_have_perl" != "xno"; th
     save_LDFLAGS="$LDFLAGS"
--   LDFLAGS="$PERL_LDFLAGS"
-+   LDFLAGS="${PERL_LDFLAGS}"
+    LDFLAGS="$PERL_LDFLAGS"
     AC_CHECK_LIB([perl], [perl_alloc], ac_cv_use_libperl=yes, ac_cv_use_libperl=no)
 -   LDFLAGS="$save_LDFLAGS"
 +   LDFLAGS+="$save_LDFLAGS"