[net] Telephony: yate: Added needed libraries and flags to configure for Yate to...
[packages.git] / net / ctorrent / Makefile
index d2664f5..522fea5 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ctorrent
 PKG_VERSION:=dnh3.3.2
-PKG_RELEASE:=3
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/dtorrent \
@@ -26,6 +26,7 @@ define Package/ctorrent/Default
   CATEGORY:=Network
   DEPENDS:=+uclibcxx
   TITLE:=console-based BitTorrent client
+  MAINTAINER:=Peter Wagner <tripolar@gmx.at>
   URL:=http://www.rahul.net/dholmes/ctorrent/
 endef
 
@@ -60,7 +61,8 @@ endef
 
 CONFIGURE_VARS += \
        CXX="g++-uc" \
-       CXXFLAGS="$$$$CXXFLAGS -fno-rtti" 
+       CXXFLAGS="$$$$CXXFLAGS -fno-rtti" \
+       LIBS="-nodefaultlibs -luClibc++ $(LIBGCC_S) -lc"
 
 ifeq ($(BUILD_VARIANT),ssl)
        CONFIGURE_ARGS += \