Add PKG_LICENSE variable to the most of the packages.
[feed/telephony.git] / libs / spandsp / Makefile
index 4abae1f..da29e1e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=spandsp
 PKG_VERSION:=0.0.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.soft-switch.org/downloads/spandsp/
@@ -19,14 +19,18 @@ PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 PKG_FIXUP:=autoreconf
 
+PKG_LICENSE:=LGPL-2.1
+PKG_LICENSE_FILES:=COPYING
+PKG_MAINTAINER:=Jiri Slachta <slachta@cesnet.cz>
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libspandsp
+  SUBMENU:=Telephony
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=spandsp library
   DEPENDS:=+libtiff
-  MAINTAINER:=Jiri Slachta <slachta@cesnet.cz>
 endef
 
 TARGET_CFLAGS += $(FPIC)
@@ -41,6 +45,9 @@ define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/spandsp
        $(CP) $(PKG_INSTALL_DIR)/usr/include/spandsp/*.h $(1)/usr/include/spandsp/
 
+       $(INSTALL_DIR) $(1)/usr/include/spandsp/private
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/spandsp/private/*.h $(1)/usr/include/spandsp/private/
+
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/spandsp.pc $(1)/usr/lib/pkgconfig/
 endef