wget: forcefully disable libuuid (#13746)
[packages.git] / libs / pwlib / Makefile
index 59b2579..84e4f3e 100644 (file)
@@ -1,16 +1,15 @@
 # 
-# Copyright (C) 2006-2007 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pwlib
 PKG_VERSION:=1.11.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://peternixon.net/pub/voxgratia
@@ -33,7 +32,7 @@ define Package/pwlib/description
  System.
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -fpermissive
 
 CONFIGURE_ARGS += \
        --enable-minsize \
@@ -51,7 +50,6 @@ CONFIGURE_ARGS += \
        --disable-ftp \
        --enable-http \
        --disable-httpsvc \
-       --disable-ipv6 \
        --disable-jabber \
        --disable-openldap \
        --disable-openssl \