packages/libsdl_sound: fix whitespaces
[packages.git] / libs / libsdl_sound / Makefile
index 2d19537..a8549d2 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -9,15 +9,19 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsdl-sound
 PKG_VERSION:=1.0.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=SDL_sound-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://icculus.org/SDL_sound/downloads/
 PKG_MD5SUM:=aa09cd52df85d29bee87a664424c94b5
+
 PKG_BUILD_DIR:=$(BUILD_DIR)/SDL_sound-$(PKG_VERSION)
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+TARGET_LDFLAGS += -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
+
 define Package/libsdl-sound
   SECTION:=libs
   CATEGORY:=Libraries
@@ -31,20 +35,14 @@ define Package/libsdl-sound/description
   of several popular sound file formats, such as .WAV and .MP3.
 endef
 
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/SDL
-
 CONFIGURE_ARGS += \
-       --with-sdl-exec-prefix=$(STAGING_DIR)
-
-CONFIGURE_VARS += \
-       LIBS="-lSDL -ldirect -ldirectfb -lfusion"
-
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+       --with-sdl-prefix="$(STAGING_DIR)/usr" \
+       --disable-flac \
+       --disable-mikmod \
+       --disable-modplug \
+       --disable-ogg \
+       --disable-smpeg \
+       --disable-speex \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/SDL $(1)/usr/lib
@@ -58,7 +56,7 @@ endef
 
 define Package/libsdl-sound/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libSDL_sound*.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libSDL_sound*.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libsdl-sound))