python packages cleanup, add some missing deps
[packages.git] / lang / egenix-mx / Makefile
index 7e5001b..35bdcf0 100644 (file)
@@ -21,9 +21,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-egenix-mx
   SUBMENU:=Python
@@ -40,6 +37,7 @@ define Package/python-egenix-mx/description
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                build --build-lib="foo", \
                BASECFLAGS="$(TARGET_CFLAGS)" \