build: add a config option for choosing the prefered standard c++ library and add...
[openwrt.git] / include / uclibc++.mk
diff --git a/include/uclibc++.mk b/include/uclibc++.mk
new file mode 100644 (file)
index 0000000..8174843
--- /dev/null
@@ -0,0 +1,12 @@
+ifndef DUMP
+  ifdef __package_mk
+    $(error uclibc++.mk must be included before package.mk)
+  endif
+endif
+
+PKG_PREPARED_DEPENDS += CONFIG_USE_UCLIBCXX
+CXX_DEPENDS = +USE_UCLIBCXX:uclibcxx +USE_LIBSTDCXX:libstdcpp
+
+ifneq ($(CONFIG_USE_UCLIBCXX),)
+  TARGET_CXX="g++-uc"
+endif