merge the scripts dealing with package/target metadata to remove some redundant code
[openwrt.git] / include / target.mk
index 042e85d..bd3ceb9 100644 (file)
@@ -7,6 +7,11 @@
 
 include $(TMP_DIR)/.target.mk
 
+ifeq ($(IB),1)
+$(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
+       $(CP) $< $@
+else
 $(TMP_DIR)/.target.mk: $(TMP_DIR)/.targetinfo
-       $(SCRIPT_DIR)/gen_target_mk.pl < $(TMP_DIR)/.targetinfo > $@
+       $(SCRIPT_DIR)/metadata.pl target_mk < $(TMP_DIR)/.targetinfo > $@
+endif