mark shfs as 2.4 only, it is broken on 2.6.23 and unmaintained. 2.6 targets can use...
[openwrt.git] / include / target.mk
index 1590b91..011992b 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -12,9 +12,6 @@ endif
 ifneq ($(__target_inc),1)
 __target_inc=1
 
-TARGET_BUILD?=0
-
-
 target_conf=$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
 ifeq ($(DUMP),)
   PLATFORM_DIR:=$(TOPDIR)/target/linux/$(BOARD)
@@ -75,10 +72,22 @@ define Profile
   endif
 endef
 
-ifeq ($(DUMP)$(if $(TARGET_BUILD),,1),)
-  -include $(PLATFORM_DIR)/profiles/*.mk
-  ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+  define IncludeProfiles
+    -include $(PLATFORM_DIR)/profiles/*.mk
     -include $(PLATFORM_SUBDIR)/profiles/*.mk
+  endef
+else
+  define IncludeProfiles
+    -include $(PLATFORM_DIR)/profiles/*.mk
+  endef
+endif
+
+ifeq ($(TARGET_BUILD),1)
+  $(eval $(call IncludeProfiles))
+else
+  ifeq ($(DUMP),)
+    $(eval $(call IncludeProfiles))
   endif
 endif
 
@@ -138,6 +147,7 @@ define BuildTargets/DumpCurrent
         echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'; \
         echo 'Target-Arch: $(ARCH)'; \
         echo 'Target-Features: $(FEATURES)'; \
+        echo 'Target-Depends: $(DEPENDS)'; \
         echo 'Linux-Version: $(LINUX_VERSION)'; \
         echo 'Linux-Release: $(LINUX_RELEASE)'; \
         echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \